summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make-fulldeps/allow-non-lint-warnings-cmdline
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/allow-non-lint-warnings-cmdline')
-rw-r--r--tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile11
-rw-r--r--tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/foo.rs5
2 files changed, 16 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile b/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
new file mode 100644
index 000000000..60d9c7c37
--- /dev/null
+++ b/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
@@ -0,0 +1,11 @@
+include ../tools.mk
+
+# Test that -A warnings makes the 'empty trait list for derive' warning go away
+OUT=$(shell $(RUSTC) foo.rs -A warnings 2>&1 | grep "warning" )
+
+all: foo
+ test -z '$(OUT)'
+
+# This is just to make sure the above command actually succeeds
+foo:
+ $(RUSTC) foo.rs -A warnings
diff --git a/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/foo.rs b/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/foo.rs
new file mode 100644
index 000000000..46e72da2d
--- /dev/null
+++ b/tests/run-make-fulldeps/allow-non-lint-warnings-cmdline/foo.rs
@@ -0,0 +1,5 @@
+#[derive()]
+#[derive(Copy, Clone)]
+pub struct Foo;
+
+pub fn main() { }