summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/c-link-to-rust-dylib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/c-link-to-rust-dylib
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/c-link-to-rust-dylib')
-rw-r--r--tests/run-make-fulldeps/c-link-to-rust-dylib/Makefile17
-rw-r--r--tests/run-make-fulldeps/c-link-to-rust-dylib/bar.c6
-rw-r--r--tests/run-make-fulldeps/c-link-to-rust-dylib/foo.rs4
3 files changed, 0 insertions, 27 deletions
diff --git a/tests/run-make-fulldeps/c-link-to-rust-dylib/Makefile b/tests/run-make-fulldeps/c-link-to-rust-dylib/Makefile
deleted file mode 100644
index 2a371b545..000000000
--- a/tests/run-make-fulldeps/c-link-to-rust-dylib/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-include ../tools.mk
-
-all: $(TMPDIR)/$(call BIN,bar)
- $(call RUN,bar)
- $(call REMOVE_DYLIBS,foo)
- $(call FAIL,bar)
-
-ifdef IS_MSVC
-$(TMPDIR)/$(call BIN,bar): $(call DYLIB,foo)
- $(CC) bar.c $(TMPDIR)/foo.dll.lib $(call OUT_EXE,bar)
-else
-$(TMPDIR)/$(call BIN,bar): $(call DYLIB,foo)
- $(CC) bar.c -lfoo -o $(call RUN_BINFILE,bar) -L $(TMPDIR)
-endif
-
-$(call DYLIB,foo): foo.rs
- $(RUSTC) foo.rs
diff --git a/tests/run-make-fulldeps/c-link-to-rust-dylib/bar.c b/tests/run-make-fulldeps/c-link-to-rust-dylib/bar.c
deleted file mode 100644
index bb4036b06..000000000
--- a/tests/run-make-fulldeps/c-link-to-rust-dylib/bar.c
+++ /dev/null
@@ -1,6 +0,0 @@
-void foo();
-
-int main() {
- foo();
- return 0;
-}
diff --git a/tests/run-make-fulldeps/c-link-to-rust-dylib/foo.rs b/tests/run-make-fulldeps/c-link-to-rust-dylib/foo.rs
deleted file mode 100644
index f197fa513..000000000
--- a/tests/run-make-fulldeps/c-link-to-rust-dylib/foo.rs
+++ /dev/null
@@ -1,4 +0,0 @@
-#![crate_type = "dylib"]
-
-#[no_mangle]
-pub extern "C" fn foo() {}