summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/c-unwind-abi-catch-lib-panic/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/c-unwind-abi-catch-lib-panic/Makefile
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/c-unwind-abi-catch-lib-panic/Makefile')
-rw-r--r--tests/run-make-fulldeps/c-unwind-abi-catch-lib-panic/Makefile30
1 files changed, 0 insertions, 30 deletions
diff --git a/tests/run-make-fulldeps/c-unwind-abi-catch-lib-panic/Makefile b/tests/run-make-fulldeps/c-unwind-abi-catch-lib-panic/Makefile
deleted file mode 100644
index 134f000d4..000000000
--- a/tests/run-make-fulldeps/c-unwind-abi-catch-lib-panic/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-include ../tools.mk
-
-all: archive
- # Compile `main.rs`, which will link into our library, and run it.
- $(RUSTC) main.rs
- $(call RUN,main)
-
-ifdef IS_MSVC
-archive: add.o panic.o
- # Now, create an archive using these two objects.
- $(AR) crus $(TMPDIR)/add.lib $(TMPDIR)/add.o $(TMPDIR)/panic.o
-else
-archive: add.o panic.o
- # Now, create an archive using these two objects.
- $(AR) crus $(TMPDIR)/libadd.a $(TMPDIR)/add.o $(TMPDIR)/panic.o
-endif
-
-# Compile `panic.rs` into an object file.
-#
-# Note that we invoke `rustc` directly, so we may emit an object rather
-# than an archive. We'll do that later.
-panic.o:
- $(BARE_RUSTC) $(RUSTFLAGS) \
- --out-dir $(TMPDIR) \
- --emit=obj panic.rs
-
-# Compile `add.c` into an object file.
-add.o:
- $(call COMPILE_OBJ,$(TMPDIR)/add.o,add.c)
-