summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/crate-data-smoke
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/crate-data-smoke
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/crate-data-smoke')
-rw-r--r--tests/run-make-fulldeps/crate-data-smoke/Makefile10
-rw-r--r--tests/run-make-fulldeps/crate-data-smoke/crate.rs7
-rw-r--r--tests/run-make-fulldeps/crate-data-smoke/lib.rs2
-rw-r--r--tests/run-make-fulldeps/crate-data-smoke/rlib.rs2
4 files changed, 0 insertions, 21 deletions
diff --git a/tests/run-make-fulldeps/crate-data-smoke/Makefile b/tests/run-make-fulldeps/crate-data-smoke/Makefile
deleted file mode 100644
index a453f65ff..000000000
--- a/tests/run-make-fulldeps/crate-data-smoke/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-include ../tools.mk
-
-all:
- [ `$(RUSTC) --print crate-name crate.rs` = "foo" ]
- [ `$(RUSTC) --print file-names crate.rs` = "$(call BIN,foo)" ]
- [ `$(RUSTC) --print file-names --crate-type=lib \
- --test crate.rs` = "$(call BIN,foo)" ]
- [ `$(RUSTC) --print file-names --test lib.rs` = "$(call BIN,mylib)" ]
- $(RUSTC) --print file-names lib.rs
- $(RUSTC) --print file-names rlib.rs
diff --git a/tests/run-make-fulldeps/crate-data-smoke/crate.rs b/tests/run-make-fulldeps/crate-data-smoke/crate.rs
deleted file mode 100644
index a48a6f51c..000000000
--- a/tests/run-make-fulldeps/crate-data-smoke/crate.rs
+++ /dev/null
@@ -1,7 +0,0 @@
-#![crate_name = "foo"]
-
-// Querying about the crate metadata should *not* parse the entire crate, it
-// only needs the crate attributes (which are guaranteed to be at the top) be
-// sure that if we have an error like a missing module that we can still query
-// about the crate id.
-mod error;
diff --git a/tests/run-make-fulldeps/crate-data-smoke/lib.rs b/tests/run-make-fulldeps/crate-data-smoke/lib.rs
deleted file mode 100644
index 8002f11ec..000000000
--- a/tests/run-make-fulldeps/crate-data-smoke/lib.rs
+++ /dev/null
@@ -1,2 +0,0 @@
-#![crate_name = "mylib"]
-#![crate_type = "lib"]
diff --git a/tests/run-make-fulldeps/crate-data-smoke/rlib.rs b/tests/run-make-fulldeps/crate-data-smoke/rlib.rs
deleted file mode 100644
index 47fcce4a7..000000000
--- a/tests/run-make-fulldeps/crate-data-smoke/rlib.rs
+++ /dev/null
@@ -1,2 +0,0 @@
-#![crate_name = "mylib"]
-#![crate_type = "rlib"]