summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/crate-name-priority
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make-fulldeps/crate-name-priority
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/crate-name-priority')
-rw-r--r--tests/run-make-fulldeps/crate-name-priority/Makefile11
-rw-r--r--tests/run-make-fulldeps/crate-name-priority/foo.rs1
-rw-r--r--tests/run-make-fulldeps/crate-name-priority/foo1.rs3
3 files changed, 15 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/crate-name-priority/Makefile b/tests/run-make-fulldeps/crate-name-priority/Makefile
new file mode 100644
index 000000000..08a07c325
--- /dev/null
+++ b/tests/run-make-fulldeps/crate-name-priority/Makefile
@@ -0,0 +1,11 @@
+include ../tools.mk
+
+all:
+ $(RUSTC) foo.rs
+ rm $(TMPDIR)/$(call BIN,foo)
+ $(RUSTC) foo.rs --crate-name bar
+ rm $(TMPDIR)/$(call BIN,bar)
+ $(RUSTC) foo1.rs
+ rm $(TMPDIR)/$(call BIN,foo)
+ $(RUSTC) foo1.rs -o $(TMPDIR)/$(call BIN,bar1)
+ rm $(TMPDIR)/$(call BIN,bar1)
diff --git a/tests/run-make-fulldeps/crate-name-priority/foo.rs b/tests/run-make-fulldeps/crate-name-priority/foo.rs
new file mode 100644
index 000000000..f328e4d9d
--- /dev/null
+++ b/tests/run-make-fulldeps/crate-name-priority/foo.rs
@@ -0,0 +1 @@
+fn main() {}
diff --git a/tests/run-make-fulldeps/crate-name-priority/foo1.rs b/tests/run-make-fulldeps/crate-name-priority/foo1.rs
new file mode 100644
index 000000000..4ff3bd951
--- /dev/null
+++ b/tests/run-make-fulldeps/crate-name-priority/foo1.rs
@@ -0,0 +1,3 @@
+#![crate_name = "foo"]
+
+fn main() {}