summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/dep-info-doesnt-run-much
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/dep-info-doesnt-run-much
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/dep-info-doesnt-run-much')
-rw-r--r--tests/run-make-fulldeps/dep-info-doesnt-run-much/Makefile4
-rw-r--r--tests/run-make-fulldeps/dep-info-doesnt-run-much/foo.rs5
2 files changed, 0 insertions, 9 deletions
diff --git a/tests/run-make-fulldeps/dep-info-doesnt-run-much/Makefile b/tests/run-make-fulldeps/dep-info-doesnt-run-much/Makefile
deleted file mode 100644
index b4dc44ad2..000000000
--- a/tests/run-make-fulldeps/dep-info-doesnt-run-much/Makefile
+++ /dev/null
@@ -1,4 +0,0 @@
-include ../tools.mk
-
-all:
- $(RUSTC) foo.rs --emit dep-info
diff --git a/tests/run-make-fulldeps/dep-info-doesnt-run-much/foo.rs b/tests/run-make-fulldeps/dep-info-doesnt-run-much/foo.rs
deleted file mode 100644
index 316e68129..000000000
--- a/tests/run-make-fulldeps/dep-info-doesnt-run-much/foo.rs
+++ /dev/null
@@ -1,5 +0,0 @@
-// We're only emitting dep info, so we shouldn't be running static analysis to
-// figure out that this program is erroneous.
-fn main() {
- let a: u8 = "a";
-}