summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/dylib-chain
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/dylib-chain
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/dylib-chain')
-rw-r--r--tests/run-make-fulldeps/dylib-chain/Makefile12
-rw-r--r--tests/run-make-fulldeps/dylib-chain/m1.rs2
-rw-r--r--tests/run-make-fulldeps/dylib-chain/m2.rs4
-rw-r--r--tests/run-make-fulldeps/dylib-chain/m3.rs4
-rw-r--r--tests/run-make-fulldeps/dylib-chain/m4.rs3
5 files changed, 0 insertions, 25 deletions
diff --git a/tests/run-make-fulldeps/dylib-chain/Makefile b/tests/run-make-fulldeps/dylib-chain/Makefile
deleted file mode 100644
index 1139822f4..000000000
--- a/tests/run-make-fulldeps/dylib-chain/Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
-include ../tools.mk
-
-all:
- $(RUSTC) m1.rs -C prefer-dynamic
- $(RUSTC) m2.rs -C prefer-dynamic
- $(RUSTC) m3.rs -C prefer-dynamic
- $(RUSTC) m4.rs
- $(call RUN,m4)
- $(call REMOVE_DYLIBS,m1)
- $(call REMOVE_DYLIBS,m2)
- $(call REMOVE_DYLIBS,m3)
- $(call FAIL,m4)
diff --git a/tests/run-make-fulldeps/dylib-chain/m1.rs b/tests/run-make-fulldeps/dylib-chain/m1.rs
deleted file mode 100644
index 08c3f3752..000000000
--- a/tests/run-make-fulldeps/dylib-chain/m1.rs
+++ /dev/null
@@ -1,2 +0,0 @@
-#![crate_type = "dylib"]
-pub fn m1() {}
diff --git a/tests/run-make-fulldeps/dylib-chain/m2.rs b/tests/run-make-fulldeps/dylib-chain/m2.rs
deleted file mode 100644
index 62176ddc9..000000000
--- a/tests/run-make-fulldeps/dylib-chain/m2.rs
+++ /dev/null
@@ -1,4 +0,0 @@
-#![crate_type = "dylib"]
-extern crate m1;
-
-pub fn m2() { m1::m1() }
diff --git a/tests/run-make-fulldeps/dylib-chain/m3.rs b/tests/run-make-fulldeps/dylib-chain/m3.rs
deleted file mode 100644
index d213aeda9..000000000
--- a/tests/run-make-fulldeps/dylib-chain/m3.rs
+++ /dev/null
@@ -1,4 +0,0 @@
-#![crate_type = "dylib"]
-extern crate m2;
-
-pub fn m3() { m2::m2() }
diff --git a/tests/run-make-fulldeps/dylib-chain/m4.rs b/tests/run-make-fulldeps/dylib-chain/m4.rs
deleted file mode 100644
index fa8ec6079..000000000
--- a/tests/run-make-fulldeps/dylib-chain/m4.rs
+++ /dev/null
@@ -1,3 +0,0 @@
-extern crate m3;
-
-fn main() { m3::m3() }