summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/error-found-staticlib-instead-crate
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/error-found-staticlib-instead-crate
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/error-found-staticlib-instead-crate')
-rw-r--r--tests/run-make-fulldeps/error-found-staticlib-instead-crate/Makefile5
-rw-r--r--tests/run-make-fulldeps/error-found-staticlib-instead-crate/bar.rs5
-rw-r--r--tests/run-make-fulldeps/error-found-staticlib-instead-crate/foo.rs1
3 files changed, 0 insertions, 11 deletions
diff --git a/tests/run-make-fulldeps/error-found-staticlib-instead-crate/Makefile b/tests/run-make-fulldeps/error-found-staticlib-instead-crate/Makefile
deleted file mode 100644
index 0eae41d72..000000000
--- a/tests/run-make-fulldeps/error-found-staticlib-instead-crate/Makefile
+++ /dev/null
@@ -1,5 +0,0 @@
-include ../tools.mk
-
-all:
- $(RUSTC) foo.rs --crate-type staticlib
- $(RUSTC) bar.rs 2>&1 | $(CGREP) "found staticlib"
diff --git a/tests/run-make-fulldeps/error-found-staticlib-instead-crate/bar.rs b/tests/run-make-fulldeps/error-found-staticlib-instead-crate/bar.rs
deleted file mode 100644
index fe35f1f8e..000000000
--- a/tests/run-make-fulldeps/error-found-staticlib-instead-crate/bar.rs
+++ /dev/null
@@ -1,5 +0,0 @@
-extern crate foo;
-
-fn main() {
- foo::foo();
-}
diff --git a/tests/run-make-fulldeps/error-found-staticlib-instead-crate/foo.rs b/tests/run-make-fulldeps/error-found-staticlib-instead-crate/foo.rs
deleted file mode 100644
index b76b4321d..000000000
--- a/tests/run-make-fulldeps/error-found-staticlib-instead-crate/foo.rs
+++ /dev/null
@@ -1 +0,0 @@
-pub fn foo() {}