summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/error-found-staticlib-instead-crate
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make-fulldeps/error-found-staticlib-instead-crate
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/error-found-staticlib-instead-crate')
-rw-r--r--tests/run-make-fulldeps/error-found-staticlib-instead-crate/Makefile5
-rw-r--r--tests/run-make-fulldeps/error-found-staticlib-instead-crate/bar.rs5
-rw-r--r--tests/run-make-fulldeps/error-found-staticlib-instead-crate/foo.rs1
3 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/error-found-staticlib-instead-crate/Makefile b/tests/run-make-fulldeps/error-found-staticlib-instead-crate/Makefile
new file mode 100644
index 000000000..0eae41d72
--- /dev/null
+++ b/tests/run-make-fulldeps/error-found-staticlib-instead-crate/Makefile
@@ -0,0 +1,5 @@
+include ../tools.mk
+
+all:
+ $(RUSTC) foo.rs --crate-type staticlib
+ $(RUSTC) bar.rs 2>&1 | $(CGREP) "found staticlib"
diff --git a/tests/run-make-fulldeps/error-found-staticlib-instead-crate/bar.rs b/tests/run-make-fulldeps/error-found-staticlib-instead-crate/bar.rs
new file mode 100644
index 000000000..fe35f1f8e
--- /dev/null
+++ b/tests/run-make-fulldeps/error-found-staticlib-instead-crate/bar.rs
@@ -0,0 +1,5 @@
+extern crate foo;
+
+fn main() {
+ foo::foo();
+}
diff --git a/tests/run-make-fulldeps/error-found-staticlib-instead-crate/foo.rs b/tests/run-make-fulldeps/error-found-staticlib-instead-crate/foo.rs
new file mode 100644
index 000000000..b76b4321d
--- /dev/null
+++ b/tests/run-make-fulldeps/error-found-staticlib-instead-crate/foo.rs
@@ -0,0 +1 @@
+pub fn foo() {}