summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/issue-11908
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make-fulldeps/issue-11908
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/issue-11908')
-rw-r--r--tests/run-make-fulldeps/issue-11908/Makefile21
-rw-r--r--tests/run-make-fulldeps/issue-11908/bar.rs3
-rw-r--r--tests/run-make-fulldeps/issue-11908/foo.rs1
3 files changed, 25 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/issue-11908/Makefile b/tests/run-make-fulldeps/issue-11908/Makefile
new file mode 100644
index 000000000..47005537e
--- /dev/null
+++ b/tests/run-make-fulldeps/issue-11908/Makefile
@@ -0,0 +1,21 @@
+# This test ensures that if you have the same rlib or dylib at two locations
+# in the same path that you don't hit an assertion in the compiler.
+#
+# Note that this relies on `liburl` to be in the path somewhere else,
+# and then our aux-built libraries will collide with liburl (they have
+# the same version listed)
+
+include ../tools.mk
+
+all:
+ mkdir $(TMPDIR)/other
+ $(RUSTC) foo.rs --crate-type=dylib -C prefer-dynamic
+ mv $(call DYLIB,foo) $(TMPDIR)/other
+ $(RUSTC) foo.rs --crate-type=dylib -C prefer-dynamic
+ $(RUSTC) bar.rs -L $(TMPDIR)/other
+ rm -rf $(TMPDIR)
+ mkdir -p $(TMPDIR)/other
+ $(RUSTC) foo.rs --crate-type=rlib
+ mv $(TMPDIR)/libfoo.rlib $(TMPDIR)/other
+ $(RUSTC) foo.rs --crate-type=rlib
+ $(RUSTC) bar.rs -L $(TMPDIR)/other
diff --git a/tests/run-make-fulldeps/issue-11908/bar.rs b/tests/run-make-fulldeps/issue-11908/bar.rs
new file mode 100644
index 000000000..bb7b36c49
--- /dev/null
+++ b/tests/run-make-fulldeps/issue-11908/bar.rs
@@ -0,0 +1,3 @@
+extern crate foo;
+
+fn main() {}
diff --git a/tests/run-make-fulldeps/issue-11908/foo.rs b/tests/run-make-fulldeps/issue-11908/foo.rs
new file mode 100644
index 000000000..82b2dfe9f
--- /dev/null
+++ b/tests/run-make-fulldeps/issue-11908/foo.rs
@@ -0,0 +1 @@
+#![crate_name = "foo"]