summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/issue-51671
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make-fulldeps/issue-51671
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/issue-51671')
-rw-r--r--tests/run-make-fulldeps/issue-51671/Makefile9
-rw-r--r--tests/run-make-fulldeps/issue-51671/app.rs20
2 files changed, 29 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/issue-51671/Makefile b/tests/run-make-fulldeps/issue-51671/Makefile
new file mode 100644
index 000000000..c93645369
--- /dev/null
+++ b/tests/run-make-fulldeps/issue-51671/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# ignore-windows-msvc
+
+all:
+ $(RUSTC) --emit=obj app.rs
+ nm $(TMPDIR)/app.o | $(CGREP) rust_begin_unwind
+ nm $(TMPDIR)/app.o | $(CGREP) rust_eh_personality
+ nm $(TMPDIR)/app.o | $(CGREP) __rg_oom
diff --git a/tests/run-make-fulldeps/issue-51671/app.rs b/tests/run-make-fulldeps/issue-51671/app.rs
new file mode 100644
index 000000000..e9dc1e974
--- /dev/null
+++ b/tests/run-make-fulldeps/issue-51671/app.rs
@@ -0,0 +1,20 @@
+#![crate_type = "bin"]
+#![feature(lang_items, alloc_error_handler)]
+#![no_main]
+#![no_std]
+
+use core::alloc::Layout;
+use core::panic::PanicInfo;
+
+#[panic_handler]
+fn panic(_: &PanicInfo) -> ! {
+ loop {}
+}
+
+#[lang = "eh_personality"]
+fn eh() {}
+
+#[alloc_error_handler]
+fn oom(_: Layout) -> ! {
+ loop {}
+}