summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/issue-64153
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/issue-64153
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/issue-64153')
-rw-r--r--tests/run-make-fulldeps/issue-64153/Makefile26
-rw-r--r--tests/run-make-fulldeps/issue-64153/downstream.rs6
-rw-r--r--tests/run-make-fulldeps/issue-64153/upstream.rs6
3 files changed, 0 insertions, 38 deletions
diff --git a/tests/run-make-fulldeps/issue-64153/Makefile b/tests/run-make-fulldeps/issue-64153/Makefile
deleted file mode 100644
index f42ea620f..000000000
--- a/tests/run-make-fulldeps/issue-64153/Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
-include ../tools.mk
-
-# `llvm-objdump`'s output looks different on windows than on other platforms.
-# It should be enough to check on Unix platforms, so:
-# ignore-windows
-
-# Staticlibs don't include Rust object files from upstream crates if the same
-# code was already pulled into the lib via LTO. However, the bug described in
-# https://github.com/rust-lang/rust/issues/64153 lead to this exclusion not
-# working properly if the upstream crate was compiled with an explicit filename
-# (via `-o`).
-#
-# This test makes sure that functions defined in the upstream crates do not
-# appear twice in the final staticlib when listing all the symbols from it.
-
-all:
- $(RUSTC) --crate-type rlib upstream.rs -o $(TMPDIR)/libupstream.rlib -Ccodegen-units=1
- $(RUSTC) --crate-type staticlib downstream.rs -Clto -Ccodegen-units=1 -o $(TMPDIR)/libdownstream.a
- # Dump all the symbols from the staticlib into `syms`
- "$(LLVM_BIN_DIR)"/llvm-objdump -t $(TMPDIR)/libdownstream.a > $(TMPDIR)/syms
- # Count the global instances of `issue64153_test_function`. There'll be 2
- # if the `upstream` object file got erroneously included twice.
- # The line we are testing for with the regex looks something like:
- # 0000000000000000 g F .text.issue64153_test_function 00000023 issue64153_test_function
- grep -c -e "[[:space:]]g[[:space:]]*F[[:space:]].*issue64153_test_function" $(TMPDIR)/syms > $(TMPDIR)/count
- [ "$$(cat $(TMPDIR)/count)" -eq "1" ]
diff --git a/tests/run-make-fulldeps/issue-64153/downstream.rs b/tests/run-make-fulldeps/issue-64153/downstream.rs
deleted file mode 100644
index e03704665..000000000
--- a/tests/run-make-fulldeps/issue-64153/downstream.rs
+++ /dev/null
@@ -1,6 +0,0 @@
-extern crate upstream;
-
-#[no_mangle]
-pub extern "C" fn foo() {
- print!("1 + 1 = {}", upstream::issue64153_test_function(1));
-}
diff --git a/tests/run-make-fulldeps/issue-64153/upstream.rs b/tests/run-make-fulldeps/issue-64153/upstream.rs
deleted file mode 100644
index 861a00298..000000000
--- a/tests/run-make-fulldeps/issue-64153/upstream.rs
+++ /dev/null
@@ -1,6 +0,0 @@
-// Make this function extern "C", public, and no-mangle, so that it gets
-// exported from the downstream staticlib.
-#[no_mangle]
-pub extern "C" fn issue64153_test_function(x: u32) -> u32 {
- x + 1
-}