summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/link-cfg/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/link-cfg/Makefile
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/link-cfg/Makefile')
-rw-r--r--tests/run-make-fulldeps/link-cfg/Makefile22
1 files changed, 0 insertions, 22 deletions
diff --git a/tests/run-make-fulldeps/link-cfg/Makefile b/tests/run-make-fulldeps/link-cfg/Makefile
deleted file mode 100644
index 0b25ccded..000000000
--- a/tests/run-make-fulldeps/link-cfg/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-include ../tools.mk
-
-all: $(call DYLIB,return1) $(call DYLIB,return2) $(call NATIVE_STATICLIB,return3)
- ls $(TMPDIR)
- $(BARE_RUSTC) --print cfg --target x86_64-unknown-linux-musl | $(CGREP) crt-static
-
- $(RUSTC) no-deps.rs --cfg foo
- $(call RUN,no-deps)
- $(RUSTC) no-deps.rs --cfg bar
- $(call RUN,no-deps)
-
- $(RUSTC) dep.rs
- $(RUSTC) with-deps.rs --cfg foo
- $(call RUN,with-deps)
- $(RUSTC) with-deps.rs --cfg bar
- $(call RUN,with-deps)
-
- $(RUSTC) dep-with-staticlib.rs
- $(RUSTC) with-staticlib-deps.rs --cfg foo
- $(call RUN,with-staticlib-deps)
- $(RUSTC) with-staticlib-deps.rs --cfg bar
- $(call RUN,with-staticlib-deps)