summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/lto-readonly-lib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/lto-readonly-lib
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/lto-readonly-lib')
-rw-r--r--tests/run-make-fulldeps/lto-readonly-lib/Makefile12
-rw-r--r--tests/run-make-fulldeps/lto-readonly-lib/lib.rs1
-rw-r--r--tests/run-make-fulldeps/lto-readonly-lib/main.rs3
3 files changed, 0 insertions, 16 deletions
diff --git a/tests/run-make-fulldeps/lto-readonly-lib/Makefile b/tests/run-make-fulldeps/lto-readonly-lib/Makefile
deleted file mode 100644
index a20ecea88..000000000
--- a/tests/run-make-fulldeps/lto-readonly-lib/Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
-include ../tools.mk
-
-all:
- $(RUSTC) lib.rs
-
- # the compiler needs to copy and modify the rlib file when performing
- # LTO, so we should ensure that it can cope with the original rlib
- # being read-only.
- chmod 444 $(TMPDIR)/*.rlib
-
- $(RUSTC) main.rs -C lto
- $(call RUN,main)
diff --git a/tests/run-make-fulldeps/lto-readonly-lib/lib.rs b/tests/run-make-fulldeps/lto-readonly-lib/lib.rs
deleted file mode 100644
index c1bfaa6ca..000000000
--- a/tests/run-make-fulldeps/lto-readonly-lib/lib.rs
+++ /dev/null
@@ -1 +0,0 @@
-#![crate_type = "rlib"]
diff --git a/tests/run-make-fulldeps/lto-readonly-lib/main.rs b/tests/run-make-fulldeps/lto-readonly-lib/main.rs
deleted file mode 100644
index 69da798b3..000000000
--- a/tests/run-make-fulldeps/lto-readonly-lib/main.rs
+++ /dev/null
@@ -1,3 +0,0 @@
-extern crate lib;
-
-fn main() {}