summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/mingw-export-call-convention
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make-fulldeps/mingw-export-call-convention
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/mingw-export-call-convention')
-rw-r--r--tests/run-make-fulldeps/mingw-export-call-convention/Makefile9
-rw-r--r--tests/run-make-fulldeps/mingw-export-call-convention/foo.rs4
2 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/mingw-export-call-convention/Makefile b/tests/run-make-fulldeps/mingw-export-call-convention/Makefile
new file mode 100644
index 000000000..4a60059cc
--- /dev/null
+++ b/tests/run-make-fulldeps/mingw-export-call-convention/Makefile
@@ -0,0 +1,9 @@
+include ../tools.mk
+
+# only-windows-gnu
+
+all:
+ $(RUSTC) foo.rs
+ # FIXME: we should make sure __stdcall calling convention is used here
+ # but that only works with LLD right now
+ nm -g "$(call IMPLIB,foo)" | $(CGREP) bar
diff --git a/tests/run-make-fulldeps/mingw-export-call-convention/foo.rs b/tests/run-make-fulldeps/mingw-export-call-convention/foo.rs
new file mode 100644
index 000000000..1fec00311
--- /dev/null
+++ b/tests/run-make-fulldeps/mingw-export-call-convention/foo.rs
@@ -0,0 +1,4 @@
+#![crate_type = "cdylib"]
+
+#[no_mangle]
+pub extern "system" fn bar() {}