summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/pgo-gen-lto/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make-fulldeps/pgo-gen-lto/Makefile
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/pgo-gen-lto/Makefile')
-rw-r--r--tests/run-make-fulldeps/pgo-gen-lto/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/pgo-gen-lto/Makefile b/tests/run-make-fulldeps/pgo-gen-lto/Makefile
new file mode 100644
index 000000000..3f2f6a838
--- /dev/null
+++ b/tests/run-make-fulldeps/pgo-gen-lto/Makefile
@@ -0,0 +1,14 @@
+# needs-profiler-support
+# ignore-windows-gnu
+
+# FIXME(mati865): MinGW GCC miscompiles compiler-rt profiling library but with Clang it works
+# properly. Since we only have GCC on the CI ignore the test for now.
+
+include ../tools.mk
+
+COMPILE_FLAGS=-Copt-level=3 -Clto=fat -Cprofile-generate="$(TMPDIR)"
+
+all:
+ $(RUSTC) $(COMPILE_FLAGS) test.rs
+ $(call RUN,test) || exit 1
+ [ -e "$(TMPDIR)"/default_*.profraw ] || (echo "No .profraw file"; exit 1)