summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/profile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make-fulldeps/profile
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/profile')
-rw-r--r--tests/run-make-fulldeps/profile/Makefile12
-rw-r--r--tests/run-make-fulldeps/profile/test.rs1
2 files changed, 13 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/profile/Makefile b/tests/run-make-fulldeps/profile/Makefile
new file mode 100644
index 000000000..fffc051ad
--- /dev/null
+++ b/tests/run-make-fulldeps/profile/Makefile
@@ -0,0 +1,12 @@
+# needs-profiler-support
+
+include ../tools.mk
+
+all:
+ $(RUSTC) -g -Z profile test.rs
+ $(call RUN,test) || exit 1
+ [ -e "$(TMPDIR)/test.gcno" ] || (echo "No .gcno file"; exit 1)
+ [ -e "$(TMPDIR)/test.gcda" ] || (echo "No .gcda file"; exit 1)
+ $(RUSTC) -g -Z profile -Z profile-emit=$(TMPDIR)/abc/abc.gcda test.rs
+ $(call RUN,test) || exit 1
+ [ -e "$(TMPDIR)/abc/abc.gcda" ] || (echo "gcda file not emitted to defined path"; exit 1)
diff --git a/tests/run-make-fulldeps/profile/test.rs b/tests/run-make-fulldeps/profile/test.rs
new file mode 100644
index 000000000..f328e4d9d
--- /dev/null
+++ b/tests/run-make-fulldeps/profile/test.rs
@@ -0,0 +1 @@
+fn main() {}