summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/relocation-model/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/relocation-model/Makefile
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/relocation-model/Makefile')
-rw-r--r--tests/run-make-fulldeps/relocation-model/Makefile19
1 files changed, 0 insertions, 19 deletions
diff --git a/tests/run-make-fulldeps/relocation-model/Makefile b/tests/run-make-fulldeps/relocation-model/Makefile
deleted file mode 100644
index a31dbfd91..000000000
--- a/tests/run-make-fulldeps/relocation-model/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-include ../tools.mk
-
-all: others
- $(RUSTC) -C relocation-model=dynamic-no-pic foo.rs
- $(call RUN,foo)
-
- $(RUSTC) -C relocation-model=default foo.rs
- $(call RUN,foo)
-
- $(RUSTC) -C relocation-model=dynamic-no-pic --crate-type=dylib foo.rs --emit=link,obj
-
-ifdef IS_MSVC
-# FIXME(#28026)
-others:
-else
-others:
- $(RUSTC) -C relocation-model=static foo.rs
- $(call RUN,foo)
-endif