summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/rustdoc-error-lines
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/rustdoc-error-lines
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/rustdoc-error-lines')
-rw-r--r--tests/run-make-fulldeps/rustdoc-error-lines/Makefile13
-rw-r--r--tests/run-make-fulldeps/rustdoc-error-lines/input.rs28
2 files changed, 0 insertions, 41 deletions
diff --git a/tests/run-make-fulldeps/rustdoc-error-lines/Makefile b/tests/run-make-fulldeps/rustdoc-error-lines/Makefile
deleted file mode 100644
index 2dc30f56b..000000000
--- a/tests/run-make-fulldeps/rustdoc-error-lines/Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
-include ../tools.mk
-
-# Test that hir-tree output doesn't crash and includes
-# the string constant we would expect to see.
-
-all:
- $(RUSTDOC) --test input.rs > $(TMPDIR)/output || true
- $(CGREP) 'input.rs - foo (line 5)' < $(TMPDIR)/output
- $(CGREP) 'input.rs:7:15' < $(TMPDIR)/output
- $(CGREP) 'input.rs - bar (line 15)' < $(TMPDIR)/output
- $(CGREP) 'input.rs:17:15' < $(TMPDIR)/output
- $(CGREP) 'input.rs - bar (line 24)' < $(TMPDIR)/output
- $(CGREP) 'input.rs:26:15' < $(TMPDIR)/output
diff --git a/tests/run-make-fulldeps/rustdoc-error-lines/input.rs b/tests/run-make-fulldeps/rustdoc-error-lines/input.rs
deleted file mode 100644
index b4db182e8..000000000
--- a/tests/run-make-fulldeps/rustdoc-error-lines/input.rs
+++ /dev/null
@@ -1,28 +0,0 @@
-// Test for #45868
-
-// random #![feature] to ensure that crate attrs
-// do not offset things
-/// ```rust
-/// #![feature(bool_to_option)]
-/// let x: char = 1;
-/// ```
-pub fn foo() {
-
-}
-
-/// Add some text around the test...
-///
-/// ```rust
-/// #![feature(bool_to_option)]
-/// let x: char = 1;
-/// ```
-///
-/// ...to make sure that the line number is still correct.
-///
-/// Let's also add a second test in the same doc comment.
-///
-/// ```rust
-/// #![feature(bool_to_option)]
-/// let x: char = 1;
-/// ```
-pub fn bar() {}