summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/rustdoc-io-error
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:03 +0000
commit64d98f8ee037282c35007b64c2649055c56af1db (patch)
tree5492bcf97fce41ee1c0b1cc2add283f3e66cdab0 /tests/run-make-fulldeps/rustdoc-io-error
parentAdding debian version 1.67.1+dfsg1-1. (diff)
downloadrustc-64d98f8ee037282c35007b64c2649055c56af1db.tar.xz
rustc-64d98f8ee037282c35007b64c2649055c56af1db.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/rustdoc-io-error')
-rw-r--r--tests/run-make-fulldeps/rustdoc-io-error/Makefile20
-rw-r--r--tests/run-make-fulldeps/rustdoc-io-error/foo.rs1
2 files changed, 21 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/rustdoc-io-error/Makefile b/tests/run-make-fulldeps/rustdoc-io-error/Makefile
new file mode 100644
index 000000000..27f5ecf94
--- /dev/null
+++ b/tests/run-make-fulldeps/rustdoc-io-error/Makefile
@@ -0,0 +1,20 @@
+include ../tools.mk
+
+# This test verifies that rustdoc doesn't ICE when it encounters an IO error
+# while generating files. Ideally this would be a rustdoc-ui test, so we could
+# verify the error message as well.
+
+# ignore-windows
+# The test uses `chmod`.
+
+OUTPUT_DIR := "$(TMPDIR)/rustdoc-io-error"
+
+# This test operates by creating a temporary directory and modifying its
+# permissions so that it is not writable. We have to take special care to set
+# the permissions back to normal so that it's able to be deleted later.
+all:
+ mkdir -p $(OUTPUT_DIR)
+ chmod u-w $(OUTPUT_DIR)
+ -$(shell $(RUSTDOC) -o $(OUTPUT_DIR) foo.rs)
+ chmod u+w $(OUTPUT_DIR)
+ exit $($(.SHELLSTATUS) -eq 1)
diff --git a/tests/run-make-fulldeps/rustdoc-io-error/foo.rs b/tests/run-make-fulldeps/rustdoc-io-error/foo.rs
new file mode 100644
index 000000000..4a835673a
--- /dev/null
+++ b/tests/run-make-fulldeps/rustdoc-io-error/foo.rs
@@ -0,0 +1 @@
+pub struct Foo;