summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/static-dylib-by-default/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/static-dylib-by-default/Makefile
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/static-dylib-by-default/Makefile')
-rw-r--r--tests/run-make-fulldeps/static-dylib-by-default/Makefile16
1 files changed, 0 insertions, 16 deletions
diff --git a/tests/run-make-fulldeps/static-dylib-by-default/Makefile b/tests/run-make-fulldeps/static-dylib-by-default/Makefile
deleted file mode 100644
index eedd0b320..000000000
--- a/tests/run-make-fulldeps/static-dylib-by-default/Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
-include ../tools.mk
-
-TO_LINK := $(call DYLIB,bar)
-ifdef IS_MSVC
-LINK_ARG = $(TO_LINK:dll=dll.lib)
-else
-LINK_ARG = $(TO_LINK)
-endif
-
-all:
- $(RUSTC) foo.rs
- $(RUSTC) bar.rs
- $(CC) main.c $(call OUT_EXE,main) $(LINK_ARG) $(EXTRACFLAGS)
- rm $(TMPDIR)/*.rlib
- rm $(call DYLIB,foo)
- $(call RUN,main)