summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/std-core-cycle
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/std-core-cycle
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/std-core-cycle')
-rw-r--r--tests/run-make-fulldeps/std-core-cycle/Makefile16
-rw-r--r--tests/run-make-fulldeps/std-core-cycle/bar.rs16
-rw-r--r--tests/run-make-fulldeps/std-core-cycle/foo.rs11
3 files changed, 0 insertions, 43 deletions
diff --git a/tests/run-make-fulldeps/std-core-cycle/Makefile b/tests/run-make-fulldeps/std-core-cycle/Makefile
deleted file mode 100644
index 4f2528637..000000000
--- a/tests/run-make-fulldeps/std-core-cycle/Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
-include ../tools.mk
-
-ifeq ($(UNAME),Darwin)
-FLAGS :=
-else
-ifdef IS_WINDOWS
-FLAGS :=
-else
-FLAGS := -C link-args=-Wl,--no-undefined
-endif
-endif
-
-all:
- $(RUSTC) bar.rs
- $(RUSTC) foo.rs $(FLAGS)
- $(RUSTC) foo.rs $(FLAGS) -C panic=abort
diff --git a/tests/run-make-fulldeps/std-core-cycle/bar.rs b/tests/run-make-fulldeps/std-core-cycle/bar.rs
deleted file mode 100644
index 9f5e7c29b..000000000
--- a/tests/run-make-fulldeps/std-core-cycle/bar.rs
+++ /dev/null
@@ -1,16 +0,0 @@
-#![feature(allocator_api)]
-#![crate_type = "rlib"]
-
-use std::alloc::*;
-
-pub struct A;
-
-unsafe impl GlobalAlloc for A {
- unsafe fn alloc(&self, _: Layout) -> *mut u8 {
- loop {}
- }
-
- unsafe fn dealloc(&self, _ptr: *mut u8, _: Layout) {
- loop {}
- }
-}
diff --git a/tests/run-make-fulldeps/std-core-cycle/foo.rs b/tests/run-make-fulldeps/std-core-cycle/foo.rs
deleted file mode 100644
index 6aa6e1ac3..000000000
--- a/tests/run-make-fulldeps/std-core-cycle/foo.rs
+++ /dev/null
@@ -1,11 +0,0 @@
-#![crate_type = "cdylib"]
-
-extern crate bar;
-
-#[global_allocator]
-static A: bar::A = bar::A;
-
-#[no_mangle]
-pub extern "C" fn a(a: u32, b: u32) -> u32 {
- a / b
-}