summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/symlinked-extern/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make-fulldeps/symlinked-extern/Makefile
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/symlinked-extern/Makefile')
-rw-r--r--tests/run-make-fulldeps/symlinked-extern/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/symlinked-extern/Makefile b/tests/run-make-fulldeps/symlinked-extern/Makefile
new file mode 100644
index 000000000..058f43e85
--- /dev/null
+++ b/tests/run-make-fulldeps/symlinked-extern/Makefile
@@ -0,0 +1,11 @@
+include ../tools.mk
+
+# ignore-windows
+# `ln` is actually `cp` on msys.
+
+all:
+ $(RUSTC) foo.rs
+ mkdir -p $(TMPDIR)/other
+ ln -nsf $(TMPDIR)/libfoo.rlib $(TMPDIR)/other
+ $(RUSTC) bar.rs -L $(TMPDIR)
+ $(RUSTC) baz.rs --extern foo=$(TMPDIR)/other/libfoo.rlib -L $(TMPDIR)