summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/target-cpu-native
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make-fulldeps/target-cpu-native
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/target-cpu-native')
-rw-r--r--tests/run-make-fulldeps/target-cpu-native/Makefile20
-rw-r--r--tests/run-make-fulldeps/target-cpu-native/foo.rs2
2 files changed, 22 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/target-cpu-native/Makefile b/tests/run-make-fulldeps/target-cpu-native/Makefile
new file mode 100644
index 000000000..eb3ca1e13
--- /dev/null
+++ b/tests/run-make-fulldeps/target-cpu-native/Makefile
@@ -0,0 +1,20 @@
+include ../tools.mk
+
+# only-linux
+# only-x86_64
+#
+# I *really* don't want to deal with a cross-platform way to compare file sizes,
+# tests in `make` sort of are awful
+
+all: $(TMPDIR)/out.log
+ # Make sure no warnings about "unknown CPU `native`" were emitted
+ if [ "$$(wc -c $(TMPDIR)/out.log | cut -d' ' -f 1)" = "0" ]; then \
+ echo no warnings generated; \
+ else \
+ exit 1; \
+ fi
+
+
+$(TMPDIR)/out.log:
+ $(RUSTC) foo.rs -C target-cpu=native 2>&1 | tee $(TMPDIR)/out.log
+ $(call RUN,foo)
diff --git a/tests/run-make-fulldeps/target-cpu-native/foo.rs b/tests/run-make-fulldeps/target-cpu-native/foo.rs
new file mode 100644
index 000000000..f79c691f0
--- /dev/null
+++ b/tests/run-make-fulldeps/target-cpu-native/foo.rs
@@ -0,0 +1,2 @@
+fn main() {
+}