summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/test-harness/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make-fulldeps/test-harness/Makefile
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/test-harness/Makefile')
-rw-r--r--tests/run-make-fulldeps/test-harness/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/run-make-fulldeps/test-harness/Makefile b/tests/run-make-fulldeps/test-harness/Makefile
new file mode 100644
index 000000000..1fe059b07
--- /dev/null
+++ b/tests/run-make-fulldeps/test-harness/Makefile
@@ -0,0 +1,8 @@
+include ../tools.mk
+
+all:
+ # check that #[cfg_attr(..., ignore)] does the right thing.
+ $(RUSTC) --test test-ignore-cfg.rs --cfg ignorecfg
+ $(call RUN,test-ignore-cfg) | $(CGREP) 'shouldnotignore ... ok' 'shouldignore ... ignored'
+ $(call RUN,test-ignore-cfg --quiet) | $(CGREP) -e "^i\.$$"
+ $(call RUN,test-ignore-cfg --quiet) | $(CGREP) -v 'should'