summaryrefslogtreecommitdiffstats
path: root/tests/run-make-fulldeps/test-harness
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make-fulldeps/test-harness
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make-fulldeps/test-harness')
-rw-r--r--tests/run-make-fulldeps/test-harness/Makefile8
-rw-r--r--tests/run-make-fulldeps/test-harness/test-ignore-cfg.rs9
2 files changed, 0 insertions, 17 deletions
diff --git a/tests/run-make-fulldeps/test-harness/Makefile b/tests/run-make-fulldeps/test-harness/Makefile
deleted file mode 100644
index 1fe059b07..000000000
--- a/tests/run-make-fulldeps/test-harness/Makefile
+++ /dev/null
@@ -1,8 +0,0 @@
-include ../tools.mk
-
-all:
- # check that #[cfg_attr(..., ignore)] does the right thing.
- $(RUSTC) --test test-ignore-cfg.rs --cfg ignorecfg
- $(call RUN,test-ignore-cfg) | $(CGREP) 'shouldnotignore ... ok' 'shouldignore ... ignored'
- $(call RUN,test-ignore-cfg --quiet) | $(CGREP) -e "^i\.$$"
- $(call RUN,test-ignore-cfg --quiet) | $(CGREP) -v 'should'
diff --git a/tests/run-make-fulldeps/test-harness/test-ignore-cfg.rs b/tests/run-make-fulldeps/test-harness/test-ignore-cfg.rs
deleted file mode 100644
index 31ef131f2..000000000
--- a/tests/run-make-fulldeps/test-harness/test-ignore-cfg.rs
+++ /dev/null
@@ -1,9 +0,0 @@
-#[test]
-#[cfg_attr(ignorecfg, ignore)]
-fn shouldignore() {
-}
-
-#[test]
-#[cfg_attr(noignorecfg, ignore)]
-fn shouldnotignore() {
-}