summaryrefslogtreecommitdiffstats
path: root/tests/run-make/cdylib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/cdylib
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/cdylib')
-rw-r--r--tests/run-make/cdylib/Makefile20
-rw-r--r--tests/run-make/cdylib/bar.rs5
-rw-r--r--tests/run-make/cdylib/foo.c10
-rw-r--r--tests/run-make/cdylib/foo.rs13
4 files changed, 48 insertions, 0 deletions
diff --git a/tests/run-make/cdylib/Makefile b/tests/run-make/cdylib/Makefile
new file mode 100644
index 000000000..3c8b52695
--- /dev/null
+++ b/tests/run-make/cdylib/Makefile
@@ -0,0 +1,20 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all: $(call RUN_BINFILE,foo)
+ $(call RUN,foo)
+ rm $(call DYLIB,foo)
+ $(RUSTC) foo.rs -C lto
+ $(call RUN,foo)
+
+ifdef IS_MSVC
+$(call RUN_BINFILE,foo): $(call DYLIB,foo)
+ $(CC) $(CFLAGS) foo.c $(TMPDIR)/foo.dll.lib $(call OUT_EXE,foo)
+else
+$(call RUN_BINFILE,foo): $(call DYLIB,foo)
+ $(CC) $(CFLAGS) foo.c -lfoo -o $(call RUN_BINFILE,foo) -L $(TMPDIR)
+endif
+
+$(call DYLIB,foo):
+ $(RUSTC) bar.rs
+ $(RUSTC) foo.rs
diff --git a/tests/run-make/cdylib/bar.rs b/tests/run-make/cdylib/bar.rs
new file mode 100644
index 000000000..fe665abc7
--- /dev/null
+++ b/tests/run-make/cdylib/bar.rs
@@ -0,0 +1,5 @@
+#![crate_type = "rlib"]
+
+pub fn bar() {
+ println!("hello!");
+}
diff --git a/tests/run-make/cdylib/foo.c b/tests/run-make/cdylib/foo.c
new file mode 100644
index 000000000..154f9682e
--- /dev/null
+++ b/tests/run-make/cdylib/foo.c
@@ -0,0 +1,10 @@
+#include <assert.h>
+
+extern void foo();
+extern unsigned bar(unsigned a, unsigned b);
+
+int main() {
+ foo();
+ assert(bar(1, 2) == 3);
+ return 0;
+}
diff --git a/tests/run-make/cdylib/foo.rs b/tests/run-make/cdylib/foo.rs
new file mode 100644
index 000000000..c4069495a
--- /dev/null
+++ b/tests/run-make/cdylib/foo.rs
@@ -0,0 +1,13 @@
+#![crate_type = "cdylib"]
+
+extern crate bar;
+
+#[no_mangle]
+pub extern "C" fn foo() {
+ bar::bar();
+}
+
+#[no_mangle]
+pub extern "C" fn bar(a: u32, b: u32) -> u32 {
+ a + b
+}