summaryrefslogtreecommitdiffstats
path: root/tests/run-make/dep-graph/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make/dep-graph/Makefile
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/dep-graph/Makefile')
-rw-r--r--tests/run-make/dep-graph/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/dep-graph/Makefile b/tests/run-make/dep-graph/Makefile
new file mode 100644
index 000000000..ae97b1672
--- /dev/null
+++ b/tests/run-make/dep-graph/Makefile
@@ -0,0 +1,12 @@
+include ../../run-make-fulldeps/tools.mk
+
+# ignore-cross-compile
+
+# Just verify that we successfully run and produce dep graphs when requested.
+
+all:
+ RUST_DEP_GRAPH=$(TMPDIR)/dep-graph $(RUSTC) \
+ -Cincremental=$(TMPDIR)/incr \
+ -Zquery-dep-graph -Zdump-dep-graph foo.rs
+ test -f $(TMPDIR)/dep-graph.txt
+ test -f $(TMPDIR)/dep-graph.dot