summaryrefslogtreecommitdiffstats
path: root/tests/run-make/doctests-keep-binaries/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/doctests-keep-binaries/Makefile
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/doctests-keep-binaries/Makefile')
-rw-r--r--tests/run-make/doctests-keep-binaries/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/run-make/doctests-keep-binaries/Makefile b/tests/run-make/doctests-keep-binaries/Makefile
new file mode 100644
index 000000000..6254e93d3
--- /dev/null
+++ b/tests/run-make/doctests-keep-binaries/Makefile
@@ -0,0 +1,22 @@
+# ignore-cross-compile
+include ../tools.mk
+
+# Check that valid binaries are persisted by running them, regardless of whether the --run or --no-run option is used.
+
+all: run no_run
+
+run:
+ mkdir -p $(TMPDIR)/doctests
+ $(RUSTC) --crate-type rlib t.rs
+ $(RUSTDOC) -Zunstable-options --test --persist-doctests $(TMPDIR)/doctests --extern t=$(TMPDIR)/libt.rlib t.rs
+ $(TMPDIR)/doctests/t_rs_2_0/rust_out
+ $(TMPDIR)/doctests/t_rs_8_0/rust_out
+ rm -rf $(TMPDIR)/doctests
+
+no_run:
+ mkdir -p $(TMPDIR)/doctests
+ $(RUSTC) --crate-type rlib t.rs
+ $(RUSTDOC) -Zunstable-options --test --persist-doctests $(TMPDIR)/doctests --extern t=$(TMPDIR)/libt.rlib t.rs --no-run
+ $(TMPDIR)/doctests/t_rs_2_0/rust_out
+ $(TMPDIR)/doctests/t_rs_8_0/rust_out
+ rm -rf $(TMPDIR)/doctests