summaryrefslogtreecommitdiffstats
path: root/tests/run-make/error-writing-dependencies
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/error-writing-dependencies
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/error-writing-dependencies')
-rw-r--r--tests/run-make/error-writing-dependencies/Makefile8
-rw-r--r--tests/run-make/error-writing-dependencies/foo.rs1
2 files changed, 9 insertions, 0 deletions
diff --git a/tests/run-make/error-writing-dependencies/Makefile b/tests/run-make/error-writing-dependencies/Makefile
new file mode 100644
index 000000000..a5d30a647
--- /dev/null
+++ b/tests/run-make/error-writing-dependencies/Makefile
@@ -0,0 +1,8 @@
+include ../tools.mk
+
+all:
+ # Let's get a nice error message
+ $(BARE_RUSTC) foo.rs --emit dep-info --out-dir foo/bar/baz 2>&1 | \
+ $(CGREP) "error writing dependencies"
+ # Make sure the filename shows up
+ $(BARE_RUSTC) foo.rs --emit dep-info --out-dir foo/bar/baz 2>&1 | $(CGREP) "baz"
diff --git a/tests/run-make/error-writing-dependencies/foo.rs b/tests/run-make/error-writing-dependencies/foo.rs
new file mode 100644
index 000000000..f328e4d9d
--- /dev/null
+++ b/tests/run-make/error-writing-dependencies/foo.rs
@@ -0,0 +1 @@
+fn main() {}