summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-30063
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/issue-30063
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/issue-30063')
-rw-r--r--tests/run-make/issue-30063/Makefile36
-rw-r--r--tests/run-make/issue-30063/foo.rs1
2 files changed, 37 insertions, 0 deletions
diff --git a/tests/run-make/issue-30063/Makefile b/tests/run-make/issue-30063/Makefile
new file mode 100644
index 000000000..8a69ca79f
--- /dev/null
+++ b/tests/run-make/issue-30063/Makefile
@@ -0,0 +1,36 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ rm -f $(TMPDIR)/foo-output
+ $(RUSTC) -C codegen-units=4 -o $(TMPDIR)/foo-output foo.rs
+ rm $(TMPDIR)/foo-output
+
+ rm -f $(TMPDIR)/asm-output
+ $(RUSTC) -C codegen-units=4 --emit=asm -o $(TMPDIR)/asm-output foo.rs
+ rm $(TMPDIR)/asm-output
+
+ rm -f $(TMPDIR)/bc-output
+ $(RUSTC) -C codegen-units=4 --emit=llvm-bc -o $(TMPDIR)/bc-output foo.rs
+ rm $(TMPDIR)/bc-output
+
+ rm -f $(TMPDIR)/ir-output
+ $(RUSTC) -C codegen-units=4 --emit=llvm-ir -o $(TMPDIR)/ir-output foo.rs
+ rm $(TMPDIR)/ir-output
+
+ rm -f $(TMPDIR)/link-output
+ $(RUSTC) -C codegen-units=4 --emit=link -o $(TMPDIR)/link-output foo.rs
+ rm $(TMPDIR)/link-output
+
+ rm -f $(TMPDIR)/obj-output
+ $(RUSTC) -C codegen-units=4 --emit=obj -o $(TMPDIR)/obj-output foo.rs
+ rm $(TMPDIR)/obj-output
+
+ rm -f $(TMPDIR)/dep-output
+ $(RUSTC) -C codegen-units=4 --emit=dep-info -o $(TMPDIR)/dep-output foo.rs
+ rm $(TMPDIR)/dep-output
+
+# # (This case doesn't work yet, and may be fundamentally wrong-headed anyway.)
+# rm -f $(TMPDIR)/multi-output
+# $(RUSTC) -C codegen-units=4 --emit=asm,obj -o $(TMPDIR)/multi-output foo.rs
+# rm $(TMPDIR)/multi-output
diff --git a/tests/run-make/issue-30063/foo.rs b/tests/run-make/issue-30063/foo.rs
new file mode 100644
index 000000000..45590d86b
--- /dev/null
+++ b/tests/run-make/issue-30063/foo.rs
@@ -0,0 +1 @@
+fn main() { }