summaryrefslogtreecommitdiffstats
path: root/tests/run-make/issue-83045/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/issue-83045/Makefile
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/issue-83045/Makefile')
-rw-r--r--tests/run-make/issue-83045/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/run-make/issue-83045/Makefile b/tests/run-make/issue-83045/Makefile
new file mode 100644
index 000000000..7053da00f
--- /dev/null
+++ b/tests/run-make/issue-83045/Makefile
@@ -0,0 +1,33 @@
+include ../tools.mk
+
+# This test case creates a situation where the crate loader would run
+# into an ICE when confronted with an invalid setup where it cannot
+# find the dependency of a direct dependency.
+#
+# The test case makes sure that the compiler produces the expected
+# error message but does not ICE immediately after.
+#
+# See https://github.com/rust-lang/rust/issues/83045
+
+# This is a platform-independent issue, no need to waste time testing
+# everywhere.
+# only-x86_64
+# only-linux
+
+# NOTE: We use BARE_RUSTC below so that the compiler can't find liba.rlib
+# If we used RUSTC the additional '-L TMPDIR' option would allow rustc to
+# actually find the crate.
+#
+# We check that we get the expected error message
+# But that we do not get an ICE
+
+all:
+ $(RUSTC) --crate-name=a --crate-type=rlib a.rs --verbose
+ $(RUSTC) --crate-name=b --crate-type=rlib --extern a=$(TMPDIR)/liba.rlib b.rs --verbose
+ $(BARE_RUSTC) --out-dir $(TMPDIR) \
+ --extern b=$(TMPDIR)/libb.rlib \
+ --crate-type=rlib \
+ --edition=2018 \
+ c.rs 2>&1 | tee $(TMPDIR)/output.txt || exit 0
+ $(CGREP) E0519 < $(TMPDIR)/output.txt
+ $(CGREP) -v "internal compiler error" < $(TMPDIR)/output.txt