summaryrefslogtreecommitdiffstats
path: root/tests/run-make/native-link-modifier-bundle/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make/native-link-modifier-bundle/Makefile
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/native-link-modifier-bundle/Makefile')
-rw-r--r--tests/run-make/native-link-modifier-bundle/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/run-make/native-link-modifier-bundle/Makefile b/tests/run-make/native-link-modifier-bundle/Makefile
new file mode 100644
index 000000000..7c78d7783
--- /dev/null
+++ b/tests/run-make/native-link-modifier-bundle/Makefile
@@ -0,0 +1,33 @@
+# ignore-cross-compile
+# ignore-windows-msvc
+
+include ../../run-make-fulldeps/tools.mk
+
+# We're using the llvm-nm instead of the system nm to ensure it is compatible
+# with the LLVM bitcode generated by rustc.
+NM = "$(LLVM_BIN_DIR)"/llvm-nm
+
+all: $(call NATIVE_STATICLIB,native-staticlib)
+ # Build a staticlib and a rlib, the `native_func` symbol will be bundled into them
+ $(RUSTC) bundled.rs --crate-type=staticlib --crate-type=rlib
+ $(NM) $(TMPDIR)/libbundled.a | $(CGREP) -e "T _*native_func"
+ $(NM) $(TMPDIR)/libbundled.a | $(CGREP) -e "U _*native_func"
+ $(NM) $(TMPDIR)/libbundled.rlib | $(CGREP) -e "T _*native_func"
+ $(NM) $(TMPDIR)/libbundled.rlib | $(CGREP) -e "U _*native_func"
+
+ # Build a staticlib and a rlib, the `native_func` symbol will not be bundled into it
+ $(RUSTC) non-bundled.rs --crate-type=staticlib --crate-type=rlib
+ $(NM) $(TMPDIR)/libnon_bundled.a | $(CGREP) -ve "T _*native_func"
+ $(NM) $(TMPDIR)/libnon_bundled.a | $(CGREP) -e "U _*native_func"
+ $(NM) $(TMPDIR)/libnon_bundled.rlib | $(CGREP) -ve "T _*native_func"
+ $(NM) $(TMPDIR)/libnon_bundled.rlib | $(CGREP) -e "U _*native_func"
+
+ # Build a cdylib, `native-staticlib` will not appear on the linker line because it was bundled previously
+ # The cdylib will contain the `native_func` symbol in the end
+ $(RUSTC) cdylib-bundled.rs --crate-type=cdylib --print link-args | $(CGREP) -ve '-l[" ]*native-staticlib'
+ $(NM) $(call DYLIB,cdylib_bundled) | $(CGREP) -e "[Tt] _*native_func"
+
+ # Build a cdylib, `native-staticlib` will appear on the linker line because it was not bundled previously
+ # The cdylib will contain the `native_func` symbol in the end
+ $(RUSTC) cdylib-non-bundled.rs --crate-type=cdylib --print link-args | $(CGREP) -e '-l[" ]*native-staticlib'
+ $(NM) $(call DYLIB,cdylib_non_bundled) | $(CGREP) -e "[Tt] _*native_func"