summaryrefslogtreecommitdiffstats
path: root/tests/run-make/output-filename-overwrites-input/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/output-filename-overwrites-input/Makefile
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/output-filename-overwrites-input/Makefile')
-rw-r--r--tests/run-make/output-filename-overwrites-input/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/run-make/output-filename-overwrites-input/Makefile b/tests/run-make/output-filename-overwrites-input/Makefile
new file mode 100644
index 000000000..605b86b25
--- /dev/null
+++ b/tests/run-make/output-filename-overwrites-input/Makefile
@@ -0,0 +1,14 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ cp foo.rs $(TMPDIR)/foo
+ $(RUSTC) $(TMPDIR)/foo -o $(TMPDIR)/foo 2>&1 \
+ | $(CGREP) -e "the input file \".*foo\" would be overwritten by the generated executable"
+ cp bar.rs $(TMPDIR)/bar.rlib
+ $(RUSTC) $(TMPDIR)/bar.rlib -o $(TMPDIR)/bar.rlib 2>&1 \
+ | $(CGREP) -e "the input file \".*bar.rlib\" would be overwritten by the generated executable"
+ $(RUSTC) foo.rs 2>&1 && $(RUSTC) -Z ls $(TMPDIR)/foo 2>&1
+ cp foo.rs $(TMPDIR)/foo.rs
+ $(RUSTC) $(TMPDIR)/foo.rs -o $(TMPDIR)/foo.rs 2>&1 \
+ | $(CGREP) -e "the input file \".*foo.rs\" would be overwritten by the generated executable"