summaryrefslogtreecommitdiffstats
path: root/tests/run-make/prefer-dylib
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/prefer-dylib
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/prefer-dylib')
-rw-r--r--tests/run-make/prefer-dylib/Makefile9
-rw-r--r--tests/run-make/prefer-dylib/bar.rs1
-rw-r--r--tests/run-make/prefer-dylib/foo.rs5
3 files changed, 15 insertions, 0 deletions
diff --git a/tests/run-make/prefer-dylib/Makefile b/tests/run-make/prefer-dylib/Makefile
new file mode 100644
index 000000000..cc26e70ae
--- /dev/null
+++ b/tests/run-make/prefer-dylib/Makefile
@@ -0,0 +1,9 @@
+# ignore-cross-compile
+include ../tools.mk
+
+all:
+ $(RUSTC) bar.rs --crate-type=dylib --crate-type=rlib -C prefer-dynamic
+ $(RUSTC) foo.rs -C prefer-dynamic
+ $(call RUN,foo)
+ rm $(TMPDIR)/*bar*
+ $(call FAIL,foo)
diff --git a/tests/run-make/prefer-dylib/bar.rs b/tests/run-make/prefer-dylib/bar.rs
new file mode 100644
index 000000000..c5c0bc606
--- /dev/null
+++ b/tests/run-make/prefer-dylib/bar.rs
@@ -0,0 +1 @@
+pub fn bar() {}
diff --git a/tests/run-make/prefer-dylib/foo.rs b/tests/run-make/prefer-dylib/foo.rs
new file mode 100644
index 000000000..8d68535e3
--- /dev/null
+++ b/tests/run-make/prefer-dylib/foo.rs
@@ -0,0 +1,5 @@
+extern crate bar;
+
+fn main() {
+ bar::bar();
+}