summaryrefslogtreecommitdiffstats
path: root/tests/run-make/rustdoc-shared-flags
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/rustdoc-shared-flags
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/rustdoc-shared-flags')
-rw-r--r--tests/run-make/rustdoc-shared-flags/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/run-make/rustdoc-shared-flags/Makefile b/tests/run-make/rustdoc-shared-flags/Makefile
new file mode 100644
index 000000000..a2a7d7b36
--- /dev/null
+++ b/tests/run-make/rustdoc-shared-flags/Makefile
@@ -0,0 +1,18 @@
+include ../tools.mk
+
+all: z_help c_help list_passes
+
+c_help:
+ $(RUSTC) -C help > $(TMPDIR)/rustc.c_help.txt
+ $(RUSTDOC) -C help > $(TMPDIR)/rustdoc.c_help.txt
+ $(DIFF) $(TMPDIR)/rustc.c_help.txt $(TMPDIR)/rustdoc.c_help.txt
+
+z_help:
+ $(RUSTC) -Z help > $(TMPDIR)/rustc.z_help.txt
+ $(RUSTDOC) -Z help > $(TMPDIR)/rustdoc.z_help.txt
+ $(DIFF) $(TMPDIR)/rustc.z_help.txt $(TMPDIR)/rustdoc.z_help.txt
+
+list_passes:
+ $(RUSTC) -C passes=list > $(TMPDIR)/rustc.passes.txt
+ $(RUSTDOC) -C passes=list > $(TMPDIR)/rustdoc.passes.txt
+ $(DIFF) $(TMPDIR)/rustc.passes.txt $(TMPDIR)/rustdoc.passes.txt