summaryrefslogtreecommitdiffstats
path: root/tests/run-make/silly-file-names/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
commitef24de24a82fe681581cc130f342363c47c0969a (patch)
tree0d494f7e1a38b95c92426f58fe6eaa877303a86c /tests/run-make/silly-file-names/Makefile
parentReleasing progress-linux version 1.74.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-ef24de24a82fe681581cc130f342363c47c0969a.tar.xz
rustc-ef24de24a82fe681581cc130f342363c47c0969a.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/silly-file-names/Makefile')
-rw-r--r--tests/run-make/silly-file-names/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/run-make/silly-file-names/Makefile b/tests/run-make/silly-file-names/Makefile
new file mode 100644
index 000000000..e51266c08
--- /dev/null
+++ b/tests/run-make/silly-file-names/Makefile
@@ -0,0 +1,12 @@
+# ignore-cross-compile we need to execute the binary
+# ignore-windows we create files with < and > in their names
+
+include ../tools.mk
+
+all:
+ echo '"comes from a file with a name that begins with <"' > "$(TMPDIR)/<leading-lt"
+ echo '"comes from a file with a name that ends with >"' > "$(TMPDIR)/trailing-gt>"
+ cp silly-file-names.rs "$(TMPDIR)/silly-file-names.rs"
+ $(RUSTC) "$(TMPDIR)/silly-file-names.rs" -o "$(TMPDIR)/silly-file-names"
+ "$(TMPDIR)/silly-file-names" > "$(TMPDIR)/silly-file-names.run.stdout"
+ $(RUSTC_TEST_OP) "$(TMPDIR)/silly-file-names.run.stdout" silly-file-names.run.stdout