summaryrefslogtreecommitdiffstats
path: root/tests/run-make/track-path-dep-info
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:19:13 +0000
commit218caa410aa38c29984be31a5229b9fa717560ee (patch)
treec54bd55eeb6e4c508940a30e94c0032fbd45d677 /tests/run-make/track-path-dep-info
parentReleasing progress-linux version 1.67.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-218caa410aa38c29984be31a5229b9fa717560ee.tar.xz
rustc-218caa410aa38c29984be31a5229b9fa717560ee.zip
Merging upstream version 1.68.2+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/track-path-dep-info')
-rw-r--r--tests/run-make/track-path-dep-info/Makefile13
-rw-r--r--tests/run-make/track-path-dep-info/emojis.txt1
-rw-r--r--tests/run-make/track-path-dep-info/macro_def.rs11
-rw-r--r--tests/run-make/track-path-dep-info/macro_use.rs6
4 files changed, 31 insertions, 0 deletions
diff --git a/tests/run-make/track-path-dep-info/Makefile b/tests/run-make/track-path-dep-info/Makefile
new file mode 100644
index 000000000..ee853943f
--- /dev/null
+++ b/tests/run-make/track-path-dep-info/Makefile
@@ -0,0 +1,13 @@
+include ../../run-make-fulldeps/tools.mk
+
+# FIXME(eddyb) provide `HOST_RUSTC` and `TARGET_RUSTC`
+# instead of hardcoding them everywhere they're needed.
+ifeq ($(IS_MUSL_HOST),1)
+ADDITIONAL_ARGS := $(RUSTFLAGS)
+endif
+
+all:
+ # Proc macro
+ $(BARE_RUSTC) $(ADDITIONAL_ARGS) --out-dir $(TMPDIR) macro_def.rs
+ EXISTING_PROC_MACRO_ENV=1 $(RUSTC) --emit dep-info macro_use.rs
+ $(CGREP) "emojis.txt:" < $(TMPDIR)/macro_use.d
diff --git a/tests/run-make/track-path-dep-info/emojis.txt b/tests/run-make/track-path-dep-info/emojis.txt
new file mode 100644
index 000000000..e1a728461
--- /dev/null
+++ b/tests/run-make/track-path-dep-info/emojis.txt
@@ -0,0 +1 @@
+👾👾👾👾👾👾
diff --git a/tests/run-make/track-path-dep-info/macro_def.rs b/tests/run-make/track-path-dep-info/macro_def.rs
new file mode 100644
index 000000000..8777ce21f
--- /dev/null
+++ b/tests/run-make/track-path-dep-info/macro_def.rs
@@ -0,0 +1,11 @@
+#![feature(track_path)]
+#![crate_type = "proc-macro"]
+
+extern crate proc_macro;
+use proc_macro::*;
+
+#[proc_macro]
+pub fn access_tracked_paths(_: TokenStream) -> TokenStream {
+ tracked_path::path("emojis.txt");
+ TokenStream::new()
+}
diff --git a/tests/run-make/track-path-dep-info/macro_use.rs b/tests/run-make/track-path-dep-info/macro_use.rs
new file mode 100644
index 000000000..3c49fd05d
--- /dev/null
+++ b/tests/run-make/track-path-dep-info/macro_use.rs
@@ -0,0 +1,6 @@
+#[macro_use]
+extern crate macro_def;
+
+access_tracked_paths!();
+
+fn main() {}