summaryrefslogtreecommitdiffstats
path: root/tests/run-make/weird-output-filenames
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:20:39 +0000
commit1376c5a617be5c25655d0d7cb63e3beaa5a6e026 (patch)
tree3bb8d61aee02bc7a15eab3f36e3b921afc2075d0 /tests/run-make/weird-output-filenames
parentReleasing progress-linux version 1.69.0+dfsg1-1~progress7.99u1. (diff)
downloadrustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.tar.xz
rustc-1376c5a617be5c25655d0d7cb63e3beaa5a6e026.zip
Merging upstream version 1.70.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/run-make/weird-output-filenames')
-rw-r--r--tests/run-make/weird-output-filenames/Makefile15
-rw-r--r--tests/run-make/weird-output-filenames/foo.rs1
2 files changed, 16 insertions, 0 deletions
diff --git a/tests/run-make/weird-output-filenames/Makefile b/tests/run-make/weird-output-filenames/Makefile
new file mode 100644
index 000000000..d3a34e3b4
--- /dev/null
+++ b/tests/run-make/weird-output-filenames/Makefile
@@ -0,0 +1,15 @@
+include ../tools.mk
+
+all:
+ cp foo.rs $(TMPDIR)/.foo.rs
+ $(RUSTC) $(TMPDIR)/.foo.rs 2>&1 \
+ | $(CGREP) -e "invalid character.*in crate name:"
+ cp foo.rs $(TMPDIR)/.foo.bar
+ $(RUSTC) $(TMPDIR)/.foo.bar 2>&1 \
+ | $(CGREP) -e "invalid character.*in crate name:"
+ cp foo.rs $(TMPDIR)/+foo+bar.rs
+ $(RUSTC) $(TMPDIR)/+foo+bar.rs 2>&1 \
+ | $(CGREP) -e "invalid character.*in crate name:"
+ cp foo.rs $(TMPDIR)/-foo.rs
+ $(RUSTC) $(TMPDIR)/-foo.rs 2>&1 \
+ | $(CGREP) 'crate names cannot start with a `-`'
diff --git a/tests/run-make/weird-output-filenames/foo.rs b/tests/run-make/weird-output-filenames/foo.rs
new file mode 100644
index 000000000..f328e4d9d
--- /dev/null
+++ b/tests/run-make/weird-output-filenames/foo.rs
@@ -0,0 +1 @@
+fn main() {}