summaryrefslogtreecommitdiffstats
path: root/vendor/always-assert
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/always-assert
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/always-assert')
-rw-r--r--vendor/always-assert/.cargo-checksum.json1
-rw-r--r--vendor/always-assert/Cargo.toml29
-rw-r--r--vendor/always-assert/LICENSE-APACHE201
-rw-r--r--vendor/always-assert/LICENSE-MIT23
-rw-r--r--vendor/always-assert/README.md20
-rw-r--r--vendor/always-assert/src/lib.rs122
-rw-r--r--vendor/always-assert/tests/it.rs79
7 files changed, 475 insertions, 0 deletions
diff --git a/vendor/always-assert/.cargo-checksum.json b/vendor/always-assert/.cargo-checksum.json
new file mode 100644
index 000000000..6f93ea378
--- /dev/null
+++ b/vendor/always-assert/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"c08f962d99127c844ab8f03886adaff10962915cb3c0b2790ee4d331bc809e33","LICENSE-APACHE":"a60eea817514531668d7e00765731449fe14d059d3249e0bc93b36de45f759f2","LICENSE-MIT":"23f18e03dc49df91622fe2a76176497404e46ced8a715d9d2b67a7446571cca3","README.md":"fd6b76a4d4af25f7d39d1b0452f3779fccf66bf4a75787129a531ef2f32be593","src/lib.rs":"552e51ffa1be8614717111dd97cdafdfbfb195131373e6d4c9f2698453e782ba","tests/it.rs":"60f4b22d8c8e84db2ad6cd9f58106c9103a4d0ea3dde7dfa3657afad9c04bf8d"},"package":"fbf688625d06217d5b1bb0ea9d9c44a1635fd0ee3534466388d18203174f4d11"} \ No newline at end of file
diff --git a/vendor/always-assert/Cargo.toml b/vendor/always-assert/Cargo.toml
new file mode 100644
index 000000000..74efd7517
--- /dev/null
+++ b/vendor/always-assert/Cargo.toml
@@ -0,0 +1,29 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "always-assert"
+version = "0.1.2"
+authors = ["Aleksey Kladov <aleksey.kladov@gmail.com>"]
+exclude = [".github/", "bors.toml", "rustfmt.toml"]
+description = "Recoverable assertions for long-running robust applications"
+keywords = ["assert"]
+categories = ["development-tools::debugging"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/matklad/always-assert"
+[dependencies.log]
+version = "0.4"
+optional = true
+
+[features]
+force = []
diff --git a/vendor/always-assert/LICENSE-APACHE b/vendor/always-assert/LICENSE-APACHE
new file mode 100644
index 000000000..16fe87b06
--- /dev/null
+++ b/vendor/always-assert/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/always-assert/LICENSE-MIT b/vendor/always-assert/LICENSE-MIT
new file mode 100644
index 000000000..31aa79387
--- /dev/null
+++ b/vendor/always-assert/LICENSE-MIT
@@ -0,0 +1,23 @@
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/always-assert/README.md b/vendor/always-assert/README.md
new file mode 100644
index 000000000..7494139a1
--- /dev/null
+++ b/vendor/always-assert/README.md
@@ -0,0 +1,20 @@
+# always-assert
+
+Recoverable assertions, inspired by [the use of `assert()` in SQLite](https://www.sqlite.org/assert.html).
+
+```rust
+use always_assert::never;
+
+fn apply_transaction(&mut self, tx: Transaction) -> Result<(), TransactionAborted> {
+ let delta = self.compute_delta(&tx);
+
+ if never!(!self.check_internal_invariant(&delta)) {
+ // Ok, something in this transaction messed up our internal state.
+ // This really shouldn't be happening, and this signifies a bug.
+ // Luckily, we can recover by just rejecting the transaction.
+ return abort_transaction(tx);
+ }
+ self.commit(delta);
+ Ok(())
+}
+```
diff --git a/vendor/always-assert/src/lib.rs b/vendor/always-assert/src/lib.rs
new file mode 100644
index 000000000..4cb8653b3
--- /dev/null
+++ b/vendor/always-assert/src/lib.rs
@@ -0,0 +1,122 @@
+//! Recoverable assertions, inspired by [the use of `assert()` in
+//! SQLite](https://www.sqlite.org/assert.html).
+//!
+//! `never!` and `always!` return the actual value of the condition if
+//! `debug_assertions` are disabled.
+//!
+//! Use them when terminating on assertion failure is worse than continuing.
+//!
+//! One example would be a critical application like a database:
+//!
+//! ```ignore
+//! use always_assert::never;
+//!
+//! fn apply_transaction(&mut self, tx: Transaction) -> Result<(), TransactionAborted> {
+//! let delta = self.compute_delta(&tx);
+//!
+//! if never!(!self.check_internal_invariant(&delta)) {
+//! // Ok, something in this transaction messed up our internal state.
+//! // This really shouldn't be happening, and this signifies a bug.
+//! // Luckily, we can recover by just rejecting the transaction.
+//! return abort_transaction(tx);
+//! }
+//! self.commit(delta);
+//! Ok(())
+//! }
+//! ```
+//!
+//! Another example is assertions about non-critical functionality in usual apps
+//!
+//! ```ignore
+//! use always_assert::never;
+//!
+//! let english_message = "super app installed!"
+//! let mut local_message = localize(english_message);
+//! if never!(local_message.is_empty(), "missing localization for {}", english_message) {
+//! // We localized all the messages but this one slipper through the cracks?
+//! // Better to show the english one then than to fail outright;
+//! local_message = english_message;
+//! }
+//! println!("{}", local_message);
+//! ```
+
+/// Asserts that the condition is always true and returns its actual value.
+///
+/// If the condition is true does nothing and and evaluates to true.
+///
+/// If the condition is false:
+/// * panics if `force` feature or `debug_assertions` are enabled,
+/// * logs an error if `log` feature is enabled,
+/// * evaluates to false.
+///
+/// Accepts `format!` style arguments.
+#[macro_export]
+macro_rules! always {
+ ($cond:expr) => {
+ $crate::always!($cond, "assertion failed: {}", stringify!($cond))
+ };
+
+ ($cond:expr, $fmt:literal $($arg:tt)*) => {{
+ let cond = $cond;
+ if cfg!(debug_assertions) || $crate::__FORCE {
+ assert!(cond, $fmt $($arg)*);
+ }
+ if !cond {
+ $crate::__log_error!($fmt $($arg)*);
+ }
+ cond
+ }};
+}
+
+/// Asserts that the condition is never true and returns its actual value.
+///
+/// If the condition is false does nothing and and evaluates to false.
+///
+/// If the condition is true:
+/// * panics if `force` feature or `debug_assertions` are enabled,
+/// * logs an error if `log` feature is enabled,
+/// * evaluates to true.
+///
+/// Accepts `format!` style arguments.
+///
+/// Empty condition is equivalent to false:
+///
+/// ```ignore
+/// never!("oups") ~= unreachable!("oups")
+/// ```
+#[macro_export]
+macro_rules! never {
+ (true $($tt:tt)*) => { $crate::never!((true) $($tt)*) };
+ (false $($tt:tt)*) => { $crate::never!((false) $($tt)*) };
+ () => { $crate::never!("assertion failed: entered unreachable code") };
+ ($fmt:literal $(, $($arg:tt)*)?) => {{
+ if cfg!(debug_assertions) || $crate::__FORCE {
+ unreachable!($fmt $(, $($arg)*)?);
+ }
+ $crate::__log_error!($fmt $(, $($arg)*)?);
+ }};
+
+ ($cond:expr) => {{
+ let cond = !$crate::always!(!$cond);
+ cond
+ }};
+
+ ($cond:expr, $fmt:literal $($arg:tt)*) => {{
+ let cond = !$crate::always!(!$cond, $fmt $($arg)*);
+ cond
+ }};
+}
+
+#[cfg(feature = "log")]
+#[doc(hidden)]
+pub use log::error as __log_error;
+
+#[cfg(not(feature = "log"))]
+#[doc(hidden)]
+#[macro_export]
+macro_rules! __log_error {
+ ($($tt:tt)*) => {};
+}
+
+#[doc(hidden)]
+pub const __FORCE: bool = cfg!(feature = "force");
diff --git a/vendor/always-assert/tests/it.rs b/vendor/always-assert/tests/it.rs
new file mode 100644
index 000000000..18855787d
--- /dev/null
+++ b/vendor/always-assert/tests/it.rs
@@ -0,0 +1,79 @@
+#[cfg(any(debug_assertions, feature = "force"))]
+mod armed {
+ use always_assert::{always, never};
+
+ #[test]
+ #[should_panic = "assertion failed: 2 + 2 == 5"]
+ fn syntax1() {
+ let _: bool = always!(2 + 2 == 5);
+ }
+
+ #[test]
+ #[should_panic = "custom"]
+ fn syntax2() {
+ let _: bool = always!(2 + 2 == 5, "custom");
+ }
+
+ #[test]
+ #[should_panic = "custom 92"]
+ fn syntax3() {
+ let _: bool = always!(2 + 2 == 5, "custom {}", 92);
+ }
+
+ #[test]
+ #[should_panic = "assertion failed: !(2 + 2 == 4)"]
+ fn syntax4() {
+ let _: bool = never!(2 + 2 == 4);
+ }
+
+ #[test]
+ #[should_panic = "custom"]
+ fn syntax5() {
+ let _: bool = never!(2 + 2 == 4, "custom");
+ }
+
+ #[test]
+ #[should_panic = "custom 92"]
+ fn syntax6() {
+ let _: bool = never!(2 + 2 == 4, "custom {}", 92);
+ }
+
+ #[test]
+ #[should_panic = "unreachable code"]
+ fn syntax7() {
+ let () = never!();
+ }
+
+ #[test]
+ #[should_panic = "custom"]
+ fn syntax8() {
+ let () = never!("custom");
+ }
+
+ #[test]
+ #[should_panic = "custom"]
+ fn syntax9() {
+ let () = never!("custom");
+ }
+
+ #[test]
+ #[should_panic = "custom 92"]
+ fn syntax10() {
+ let () = never!("custom {}", 92);
+ }
+}
+
+#[cfg(all(not(debug_assertions), not(feature = "force")))]
+mod disarmed {
+ use always_assert::{always, never};
+
+ #[test]
+ fn syntax1() {
+ assert!(!always!(false));
+ }
+
+ #[test]
+ fn syntax2() {
+ assert!(never!(true));
+ }
+}