summaryrefslogtreecommitdiffstats
path: root/vendor/anstyle
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/anstyle
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/anstyle')
-rw-r--r--vendor/anstyle/.cargo-checksum.json2
-rw-r--r--vendor/anstyle/Cargo.lock2
-rw-r--r--vendor/anstyle/Cargo.toml23
-rw-r--r--vendor/anstyle/src/color.rs16
4 files changed, 22 insertions, 21 deletions
diff --git a/vendor/anstyle/.cargo-checksum.json b/vendor/anstyle/.cargo-checksum.json
index c49381758..fbf010c6c 100644
--- a/vendor/anstyle/.cargo-checksum.json
+++ b/vendor/anstyle/.cargo-checksum.json
@@ -1 +1 @@
-{"files":{"Cargo.lock":"8e369dc1909edb655963e5b0a2b1d182a96a8b114b65f84e353a1cd3a6ba06e8","Cargo.toml":"2865988fea7fbb7a54ef96cb05d5391b2f507265582fc850c92dd0e2c34786d5","LICENSE-APACHE":"c6596eb7be8581c18be736c846fb9173b69eccf6ef94c5135893ec56bd92ba08","LICENSE-MIT":"3dad3b7606dec7ce40f54546e0dd485aeb52a45d4fcdfdaf830fd8349bbe43a5","README.md":"dcb157ba695dd8f1572944cc5bf84b8f67f8bb73925a5b725a9e274c755ce1a6","examples/dump.rs":"8ccbdc02b3f939109e436c26cf7550a75d0cb6aefb59ae6ae6a59b61f0d358b4","src/color.rs":"5c97b3a38d54e2a3101ba551d2b641d8ef708f7726c3527cbabdbd3e96184757","src/effect.rs":"c622c5472ba34d368a25341ce9488674b1e8516704aba80ae308e04b28136cd5","src/lib.rs":"0106395ba7263dbee67458e5ff4038cab493a3d34f3dcf0cb75504b1531a58e1","src/macros.rs":"0c90b45626fe8331d5b3326abb831f4ba6e04bcc975b1b9c01e465715050caa2","src/reset.rs":"65658e159fdf8f018bcfe6fdcfff688dbc4f3579fe1c685abdf92af6267165f8","src/style.rs":"f17ae53e38a3551ee8e3092f259aadfafabd3103e2db7fb3af291241dc6b8f46"},"package":"41ed9a86bf92ae6580e0a31281f65a1b1d867c0cc68d5346e2ae128dddfa6a7d"} \ No newline at end of file
+{"files":{"Cargo.lock":"0afd491ec728e98a5258056e95610a470958151437feaf798897f3925fdf18a8","Cargo.toml":"0c56a3526842d6b1a2d44e4ff70816cf450843340b72d24cb037e1b6ed1668ac","LICENSE-APACHE":"c6596eb7be8581c18be736c846fb9173b69eccf6ef94c5135893ec56bd92ba08","LICENSE-MIT":"3dad3b7606dec7ce40f54546e0dd485aeb52a45d4fcdfdaf830fd8349bbe43a5","README.md":"dcb157ba695dd8f1572944cc5bf84b8f67f8bb73925a5b725a9e274c755ce1a6","examples/dump.rs":"8ccbdc02b3f939109e436c26cf7550a75d0cb6aefb59ae6ae6a59b61f0d358b4","src/color.rs":"0ded90669e83fff64ea7b2f79c6c6de79537e2b432b997e233d5807f0646b319","src/effect.rs":"c622c5472ba34d368a25341ce9488674b1e8516704aba80ae308e04b28136cd5","src/lib.rs":"0106395ba7263dbee67458e5ff4038cab493a3d34f3dcf0cb75504b1531a58e1","src/macros.rs":"0c90b45626fe8331d5b3326abb831f4ba6e04bcc975b1b9c01e465715050caa2","src/reset.rs":"65658e159fdf8f018bcfe6fdcfff688dbc4f3579fe1c685abdf92af6267165f8","src/style.rs":"f17ae53e38a3551ee8e3092f259aadfafabd3103e2db7fb3af291241dc6b8f46"},"package":"3a30da5c5f2d5e72842e00bcb57657162cdabef0931f40e2deb9b4140440cecd"} \ No newline at end of file
diff --git a/vendor/anstyle/Cargo.lock b/vendor/anstyle/Cargo.lock
index ed114e5b4..fb61f4d79 100644
--- a/vendor/anstyle/Cargo.lock
+++ b/vendor/anstyle/Cargo.lock
@@ -4,7 +4,7 @@ version = 3
[[package]]
name = "anstyle"
-version = "1.0.0"
+version = "1.0.1"
dependencies = [
"lexopt",
]
diff --git a/vendor/anstyle/Cargo.toml b/vendor/anstyle/Cargo.toml
index 946592b11..b58e6b9c5 100644
--- a/vendor/anstyle/Cargo.toml
+++ b/vendor/anstyle/Cargo.toml
@@ -13,11 +13,12 @@
edition = "2021"
rust-version = "1.64.0"
name = "anstyle"
-version = "1.0.0"
+version = "1.0.1"
include = [
"build.rs",
"src/**/*",
"Cargo.toml",
+ "Cargo.lock",
"LICENSE*",
"README.md",
"benches/**/*",
@@ -41,38 +42,38 @@ tag-prefix = ""
[[package.metadata.release.pre-release-replacements]]
file = "CHANGELOG.md"
-search = "Unreleased"
-replace = "{{version}}"
min = 1
+replace = "{{version}}"
+search = "Unreleased"
[[package.metadata.release.pre-release-replacements]]
+exactly = 1
file = "CHANGELOG.md"
-search = '\.\.\.HEAD'
replace = "...{{tag_name}}"
-exactly = 1
+search = '\.\.\.HEAD'
[[package.metadata.release.pre-release-replacements]]
file = "CHANGELOG.md"
-search = "ReleaseDate"
-replace = "{{date}}"
min = 1
+replace = "{{date}}"
+search = "ReleaseDate"
[[package.metadata.release.pre-release-replacements]]
+exactly = 1
file = "CHANGELOG.md"
-search = "<!-- next-header -->"
replace = """
<!-- next-header -->
## [Unreleased] - ReleaseDate
"""
-exactly = 1
+search = "<!-- next-header -->"
[[package.metadata.release.pre-release-replacements]]
+exactly = 1
file = "CHANGELOG.md"
-search = "<!-- next-url -->"
replace = """
<!-- next-url -->
[Unreleased]: https://github.com/rust-cli/anstyle/compare/{{tag_name}}...HEAD"""
-exactly = 1
+search = "<!-- next-url -->"
[dependencies]
diff --git a/vendor/anstyle/src/color.rs b/vendor/anstyle/src/color.rs
index 40fa7dfa9..cbf0b47a2 100644
--- a/vendor/anstyle/src/color.rs
+++ b/vendor/anstyle/src/color.rs
@@ -7,7 +7,7 @@ pub enum Color {
}
impl Color {
- /// Create a [`Style`][crate::Style] with this as the foregroun
+ /// Create a [`Style`][crate::Style] with this as the foreground
#[inline]
pub fn on(self, background: impl Into<Color>) -> crate::Style {
crate::Style::new()
@@ -15,7 +15,7 @@ impl Color {
.bg_color(Some(background.into()))
}
- /// Create a [`Style`][crate::Style] with this as the foregroun
+ /// Create a [`Style`][crate::Style] with this as the foreground
#[inline]
pub fn on_default(self) -> crate::Style {
crate::Style::new().fg_color(Some(self))
@@ -175,7 +175,7 @@ pub enum AnsiColor {
}
impl AnsiColor {
- /// Create a [`Style`][crate::Style] with this as the foregroun
+ /// Create a [`Style`][crate::Style] with this as the foreground
#[inline]
pub fn on(self, background: impl Into<Color>) -> crate::Style {
crate::Style::new()
@@ -183,7 +183,7 @@ impl AnsiColor {
.bg_color(Some(background.into()))
}
- /// Create a [`Style`][crate::Style] with this as the foregroun
+ /// Create a [`Style`][crate::Style] with this as the foreground
#[inline]
pub fn on_default(self) -> crate::Style {
crate::Style::new().fg_color(Some(self.into()))
@@ -330,7 +330,7 @@ impl AnsiColor {
pub struct Ansi256Color(pub u8);
impl Ansi256Color {
- /// Create a [`Style`][crate::Style] with this as the foregroun
+ /// Create a [`Style`][crate::Style] with this as the foreground
#[inline]
pub fn on(self, background: impl Into<Color>) -> crate::Style {
crate::Style::new()
@@ -338,7 +338,7 @@ impl Ansi256Color {
.bg_color(Some(background.into()))
}
- /// Create a [`Style`][crate::Style] with this as the foregroun
+ /// Create a [`Style`][crate::Style] with this as the foreground
#[inline]
pub fn on_default(self) -> crate::Style {
crate::Style::new().fg_color(Some(self.into()))
@@ -450,7 +450,7 @@ impl From<AnsiColor> for Ansi256Color {
pub struct RgbColor(pub u8, pub u8, pub u8);
impl RgbColor {
- /// Create a [`Style`][crate::Style] with this as the foregroun
+ /// Create a [`Style`][crate::Style] with this as the foreground
#[inline]
pub fn on(self, background: impl Into<Color>) -> crate::Style {
crate::Style::new()
@@ -458,7 +458,7 @@ impl RgbColor {
.bg_color(Some(background.into()))
}
- /// Create a [`Style`][crate::Style] with this as the foregroun
+ /// Create a [`Style`][crate::Style] with this as the foreground
#[inline]
pub fn on_default(self) -> crate::Style {
crate::Style::new().fg_color(Some(self.into()))