summaryrefslogtreecommitdiffstats
path: root/vendor/arrayvec/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/arrayvec/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/arrayvec/Cargo.toml')
-rw-r--r--vendor/arrayvec/Cargo.toml34
1 files changed, 28 insertions, 6 deletions
diff --git a/vendor/arrayvec/Cargo.toml b/vendor/arrayvec/Cargo.toml
index 54b00740c..308c6b2df 100644
--- a/vendor/arrayvec/Cargo.toml
+++ b/vendor/arrayvec/Cargo.toml
@@ -12,25 +12,40 @@
[package]
edition = "2018"
name = "arrayvec"
-version = "0.7.2"
+version = "0.7.4"
authors = ["bluss"]
description = "A vector with fixed capacity, backed by an array (it can be stored on the stack too). Implements fixed capacity ArrayVec and ArrayString."
documentation = "https://docs.rs/arrayvec/"
-keywords = ["stack", "vector", "array", "data-structure", "no_std"]
-categories = ["data-structures", "no-std"]
+readme = "README.md"
+keywords = [
+ "stack",
+ "vector",
+ "array",
+ "data-structure",
+ "no_std",
+]
+categories = [
+ "data-structures",
+ "no-std",
+]
license = "MIT OR Apache-2.0"
repository = "https://github.com/bluss/arrayvec"
+
[package.metadata.docs.rs]
-features = ["serde"]
+features = [
+ "serde",
+ "zeroize",
+]
[package.metadata.release]
no-dev-version = true
tag-name = "{{version}}"
+
[profile.bench]
-debug = true
+debug = 2
[profile.release]
-debug = true
+debug = 2
[[bench]]
name = "extend"
@@ -39,10 +54,17 @@ harness = false
[[bench]]
name = "arraystring"
harness = false
+
[dependencies.serde]
version = "1.0"
optional = true
default-features = false
+
+[dependencies.zeroize]
+version = "1.4"
+optional = true
+default-features = false
+
[dev-dependencies.bencher]
version = "0.1.4"