summaryrefslogtreecommitdiffstats
path: root/vendor/base64/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-07 05:48:48 +0000
commitef24de24a82fe681581cc130f342363c47c0969a (patch)
tree0d494f7e1a38b95c92426f58fe6eaa877303a86c /vendor/base64/Cargo.toml
parentReleasing progress-linux version 1.74.1+dfsg1-1~progress7.99u1. (diff)
downloadrustc-ef24de24a82fe681581cc130f342363c47c0969a.tar.xz
rustc-ef24de24a82fe681581cc130f342363c47c0969a.zip
Merging upstream version 1.75.0+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/base64/Cargo.toml')
-rw-r--r--vendor/base64/Cargo.toml17
1 files changed, 15 insertions, 2 deletions
diff --git a/vendor/base64/Cargo.toml b/vendor/base64/Cargo.toml
index c551663d4..2de75ab22 100644
--- a/vendor/base64/Cargo.toml
+++ b/vendor/base64/Cargo.toml
@@ -13,7 +13,7 @@
edition = "2018"
rust-version = "1.48.0"
name = "base64"
-version = "0.21.3"
+version = "0.21.5"
authors = [
"Alice Maz <alice@alicemaz.com>",
"Marshall Pierce <marshall@mpierce.org>",
@@ -41,9 +41,22 @@ debug = 2
[profile.test]
opt-level = 3
+[[example]]
+name = "base64"
+required-features = ["std"]
+
+[[test]]
+name = "tests"
+required-features = ["alloc"]
+
+[[test]]
+name = "encode"
+required-features = ["alloc"]
+
[[bench]]
name = "benchmarks"
harness = false
+required-features = ["std"]
[dev-dependencies.criterion]
version = "0.4.0"
@@ -67,4 +80,4 @@ version = "0.3.26"
[features]
alloc = []
default = ["std"]
-std = []
+std = ["alloc"]