summaryrefslogtreecommitdiffstats
path: root/vendor/base64ct/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/base64ct/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/base64ct/Cargo.toml')
-rw-r--r--vendor/base64ct/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/vendor/base64ct/Cargo.toml b/vendor/base64ct/Cargo.toml
new file mode 100644
index 000000000..c233f023a
--- /dev/null
+++ b/vendor/base64ct/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.56"
+name = "base64ct"
+version = "1.5.3"
+authors = ["RustCrypto Developers"]
+description = """
+Pure Rust implementation of Base64 (RFC 4648) which avoids any usages of
+data-dependent branches/LUTs and thereby provides portable \"best effort\"
+constant-time operation and embedded-friendly no_std support
+"""
+documentation = "https://docs.rs/base64ct"
+readme = "README.md"
+keywords = [
+ "crypto",
+ "base64",
+ "pem",
+ "phc",
+]
+categories = [
+ "cryptography",
+ "encoding",
+ "no-std",
+ "parser-implementations",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/formats/tree/master/base64ct"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dev-dependencies.base64]
+version = "0.13"
+
+[dev-dependencies.proptest]
+version = "1"
+
+[features]
+alloc = []
+std = ["alloc"]