summaryrefslogtreecommitdiffstats
path: root/vendor/bincode/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/bincode/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/bincode/Cargo.toml')
-rw-r--r--vendor/bincode/Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/vendor/bincode/Cargo.toml b/vendor/bincode/Cargo.toml
new file mode 100644
index 000000000..4c81bfc5a
--- /dev/null
+++ b/vendor/bincode/Cargo.toml
@@ -0,0 +1,37 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "bincode"
+version = "1.3.3"
+authors = ["Ty Overby <ty@pre-alpha.com>", "Francesco Mazzoli <f@mazzo.li>", "David Tolnay <dtolnay@gmail.com>", "Zoey Riordan <zoey@dos.cafe>"]
+exclude = ["logo.png", "examples/*", ".gitignore", ".travis.yml"]
+publish = true
+description = "A binary serialization / deserialization strategy that uses Serde for transforming structs into bytes and vice versa!"
+documentation = "https://docs.rs/bincode"
+readme = "./readme.md"
+keywords = ["binary", "encode", "decode", "serialize", "deserialize"]
+categories = ["encoding", "network-programming"]
+license = "MIT"
+repository = "https://github.com/servo/bincode"
+[dependencies.serde]
+version = "1.0.63"
+[dev-dependencies.serde_bytes]
+version = "0.11"
+
+[dev-dependencies.serde_derive]
+version = "1.0.27"
+
+[features]
+i128 = []
+[badges.travis-ci]
+repository = "servo/bincode"