summaryrefslogtreecommitdiffstats
path: root/vendor/block-buffer
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 12:02:58 +0000
commit698f8c2f01ea549d77d7dc3338a12e04c11057b9 (patch)
tree173a775858bd501c378080a10dca74132f05bc50 /vendor/block-buffer
parentInitial commit. (diff)
downloadrustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.tar.xz
rustc-698f8c2f01ea549d77d7dc3338a12e04c11057b9.zip
Adding upstream version 1.64.0+dfsg1.upstream/1.64.0+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/block-buffer')
-rw-r--r--vendor/block-buffer/.cargo-checksum.json1
-rw-r--r--vendor/block-buffer/CHANGELOG.md41
-rw-r--r--vendor/block-buffer/Cargo.toml25
-rw-r--r--vendor/block-buffer/LICENSE-APACHE201
-rw-r--r--vendor/block-buffer/LICENSE-MIT25
-rw-r--r--vendor/block-buffer/README.md40
-rw-r--r--vendor/block-buffer/src/lib.rs325
-rw-r--r--vendor/block-buffer/src/sealed.rs67
-rw-r--r--vendor/block-buffer/tests/mod.rs188
9 files changed, 913 insertions, 0 deletions
diff --git a/vendor/block-buffer/.cargo-checksum.json b/vendor/block-buffer/.cargo-checksum.json
new file mode 100644
index 000000000..437d1e56c
--- /dev/null
+++ b/vendor/block-buffer/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"CHANGELOG.md":"6d73524a3689766ef673022d56aa675012bb48068cc39470743a984904db72cb","Cargo.toml":"66f91b099c9807c3dbabfebf3ed42eab4be69e86ae1c759941765b5226cca3b8","LICENSE-APACHE":"a9040321c3712d8fd0b09cf52b17445de04a23a10165049ae187cd39e5c86be5","LICENSE-MIT":"d5c22aa3118d240e877ad41c5d9fa232f9c77d757d4aac0c2f943afc0a95e0ef","README.md":"9bf3545872bdad2fb41557be5cefc21a48f0c7804f8124e24b67760429036472","src/lib.rs":"73676ca504520fb62a25bcc442674774cc79cf27f5eb23fb997fc60c93504cd8","src/sealed.rs":"65afa9015a3ddb8d1a56733ef3103b1459842f69155f00cefdb235dc73255d4e","tests/mod.rs":"58ecfa416e3d30b420975aef1d7b9d52d779696c6ba3f204130cf9e8b4743b10"},"package":"0bf7fe51849ea569fd452f37822f606a5cabb684dc918707a0193fd4664ff324"} \ No newline at end of file
diff --git a/vendor/block-buffer/CHANGELOG.md b/vendor/block-buffer/CHANGELOG.md
new file mode 100644
index 000000000..13c6a9362
--- /dev/null
+++ b/vendor/block-buffer/CHANGELOG.md
@@ -0,0 +1,41 @@
+# Changelog
+All notable changes to this project will be documented in this file.
+
+The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
+and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
+
+## 0.10.2 (2021-02-08)
+### Fixed
+- Eliminate unreachable panic in `LazyBuffer::digest_blocks` ([#731])
+
+[#731]: https://github.com/RustCrypto/utils/pull/731
+
+## 0.10.1 (2021-02-05)
+### Fixed
+- Use `as_mut_ptr` to get a pointer for mutation in the `set_data` method ([#728])
+
+[#728]: https://github.com/RustCrypto/utils/pull/728
+
+## 0.10.0 (2020-12-07) [YANKED]
+### Changed
+- Significant reduction of number of unreachable panics. ([#671])
+- Added buffer kind type parameter to `BlockBuffer`, respective marker types, and type aliases. ([#671])
+- Various `BlockBuffer` method changes. ([#671])
+
+### Removed
+- `pad_with` method and dependency on `block-padding`. ([#671])
+
+[#671]: https://github.com/RustCrypto/utils/pull/671
+
+## 0.10.0 (2020-12-08)
+### Changed
+- Rename `input_block(s)` methods to `digest_block(s)`. ([#113])
+- Upgrade the `block-padding` dependency to v0.3. ([#113])
+
+### Added
+- `par_xor_data`, `xor_data`, and `set_data` methods. ([#113])
+
+### Removed
+- The `input_lazy` method. ([#113])
+
+[#113]: https://github.com/RustCrypto/utils/pull/113
diff --git a/vendor/block-buffer/Cargo.toml b/vendor/block-buffer/Cargo.toml
new file mode 100644
index 000000000..fbcd167eb
--- /dev/null
+++ b/vendor/block-buffer/Cargo.toml
@@ -0,0 +1,25 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "block-buffer"
+version = "0.10.2"
+authors = ["RustCrypto Developers"]
+description = "Buffer type for block processing of data"
+documentation = "https://docs.rs/block-buffer"
+readme = "README.md"
+keywords = ["block", "buffer"]
+categories = ["cryptography", "no-std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/RustCrypto/utils"
+[dependencies.generic-array]
+version = "0.14"
diff --git a/vendor/block-buffer/LICENSE-APACHE b/vendor/block-buffer/LICENSE-APACHE
new file mode 100644
index 000000000..78173fa2e
--- /dev/null
+++ b/vendor/block-buffer/LICENSE-APACHE
@@ -0,0 +1,201 @@
+ Apache License
+ Version 2.0, January 2004
+ http://www.apache.org/licenses/
+
+TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
+
+1. Definitions.
+
+ "License" shall mean the terms and conditions for use, reproduction,
+ and distribution as defined by Sections 1 through 9 of this document.
+
+ "Licensor" shall mean the copyright owner or entity authorized by
+ the copyright owner that is granting the License.
+
+ "Legal Entity" shall mean the union of the acting entity and all
+ other entities that control, are controlled by, or are under common
+ control with that entity. For the purposes of this definition,
+ "control" means (i) the power, direct or indirect, to cause the
+ direction or management of such entity, whether by contract or
+ otherwise, or (ii) ownership of fifty percent (50%) or more of the
+ outstanding shares, or (iii) beneficial ownership of such entity.
+
+ "You" (or "Your") shall mean an individual or Legal Entity
+ exercising permissions granted by this License.
+
+ "Source" form shall mean the preferred form for making modifications,
+ including but not limited to software source code, documentation
+ source, and configuration files.
+
+ "Object" form shall mean any form resulting from mechanical
+ transformation or translation of a Source form, including but
+ not limited to compiled object code, generated documentation,
+ and conversions to other media types.
+
+ "Work" shall mean the work of authorship, whether in Source or
+ Object form, made available under the License, as indicated by a
+ copyright notice that is included in or attached to the work
+ (an example is provided in the Appendix below).
+
+ "Derivative Works" shall mean any work, whether in Source or Object
+ form, that is based on (or derived from) the Work and for which the
+ editorial revisions, annotations, elaborations, or other modifications
+ represent, as a whole, an original work of authorship. For the purposes
+ of this License, Derivative Works shall not include works that remain
+ separable from, or merely link (or bind by name) to the interfaces of,
+ the Work and Derivative Works thereof.
+
+ "Contribution" shall mean any work of authorship, including
+ the original version of the Work and any modifications or additions
+ to that Work or Derivative Works thereof, that is intentionally
+ submitted to Licensor for inclusion in the Work by the copyright owner
+ or by an individual or Legal Entity authorized to submit on behalf of
+ the copyright owner. For the purposes of this definition, "submitted"
+ means any form of electronic, verbal, or written communication sent
+ to the Licensor or its representatives, including but not limited to
+ communication on electronic mailing lists, source code control systems,
+ and issue tracking systems that are managed by, or on behalf of, the
+ Licensor for the purpose of discussing and improving the Work, but
+ excluding communication that is conspicuously marked or otherwise
+ designated in writing by the copyright owner as "Not a Contribution."
+
+ "Contributor" shall mean Licensor and any individual or Legal Entity
+ on behalf of whom a Contribution has been received by Licensor and
+ subsequently incorporated within the Work.
+
+2. Grant of Copyright License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ copyright license to reproduce, prepare Derivative Works of,
+ publicly display, publicly perform, sublicense, and distribute the
+ Work and such Derivative Works in Source or Object form.
+
+3. Grant of Patent License. Subject to the terms and conditions of
+ this License, each Contributor hereby grants to You a perpetual,
+ worldwide, non-exclusive, no-charge, royalty-free, irrevocable
+ (except as stated in this section) patent license to make, have made,
+ use, offer to sell, sell, import, and otherwise transfer the Work,
+ where such license applies only to those patent claims licensable
+ by such Contributor that are necessarily infringed by their
+ Contribution(s) alone or by combination of their Contribution(s)
+ with the Work to which such Contribution(s) was submitted. If You
+ institute patent litigation against any entity (including a
+ cross-claim or counterclaim in a lawsuit) alleging that the Work
+ or a Contribution incorporated within the Work constitutes direct
+ or contributory patent infringement, then any patent licenses
+ granted to You under this License for that Work shall terminate
+ as of the date such litigation is filed.
+
+4. Redistribution. You may reproduce and distribute copies of the
+ Work or Derivative Works thereof in any medium, with or without
+ modifications, and in Source or Object form, provided that You
+ meet the following conditions:
+
+ (a) You must give any other recipients of the Work or
+ Derivative Works a copy of this License; and
+
+ (b) You must cause any modified files to carry prominent notices
+ stating that You changed the files; and
+
+ (c) You must retain, in the Source form of any Derivative Works
+ that You distribute, all copyright, patent, trademark, and
+ attribution notices from the Source form of the Work,
+ excluding those notices that do not pertain to any part of
+ the Derivative Works; and
+
+ (d) If the Work includes a "NOTICE" text file as part of its
+ distribution, then any Derivative Works that You distribute must
+ include a readable copy of the attribution notices contained
+ within such NOTICE file, excluding those notices that do not
+ pertain to any part of the Derivative Works, in at least one
+ of the following places: within a NOTICE text file distributed
+ as part of the Derivative Works; within the Source form or
+ documentation, if provided along with the Derivative Works; or,
+ within a display generated by the Derivative Works, if and
+ wherever such third-party notices normally appear. The contents
+ of the NOTICE file are for informational purposes only and
+ do not modify the License. You may add Your own attribution
+ notices within Derivative Works that You distribute, alongside
+ or as an addendum to the NOTICE text from the Work, provided
+ that such additional attribution notices cannot be construed
+ as modifying the License.
+
+ You may add Your own copyright statement to Your modifications and
+ may provide additional or different license terms and conditions
+ for use, reproduction, or distribution of Your modifications, or
+ for any such Derivative Works as a whole, provided Your use,
+ reproduction, and distribution of the Work otherwise complies with
+ the conditions stated in this License.
+
+5. Submission of Contributions. Unless You explicitly state otherwise,
+ any Contribution intentionally submitted for inclusion in the Work
+ by You to the Licensor shall be under the terms and conditions of
+ this License, without any additional terms or conditions.
+ Notwithstanding the above, nothing herein shall supersede or modify
+ the terms of any separate license agreement you may have executed
+ with Licensor regarding such Contributions.
+
+6. Trademarks. This License does not grant permission to use the trade
+ names, trademarks, service marks, or product names of the Licensor,
+ except as required for reasonable and customary use in describing the
+ origin of the Work and reproducing the content of the NOTICE file.
+
+7. Disclaimer of Warranty. Unless required by applicable law or
+ agreed to in writing, Licensor provides the Work (and each
+ Contributor provides its Contributions) on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+ implied, including, without limitation, any warranties or conditions
+ of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
+ PARTICULAR PURPOSE. You are solely responsible for determining the
+ appropriateness of using or redistributing the Work and assume any
+ risks associated with Your exercise of permissions under this License.
+
+8. Limitation of Liability. In no event and under no legal theory,
+ whether in tort (including negligence), contract, or otherwise,
+ unless required by applicable law (such as deliberate and grossly
+ negligent acts) or agreed to in writing, shall any Contributor be
+ liable to You for damages, including any direct, indirect, special,
+ incidental, or consequential damages of any character arising as a
+ result of this License or out of the use or inability to use the
+ Work (including but not limited to damages for loss of goodwill,
+ work stoppage, computer failure or malfunction, or any and all
+ other commercial damages or losses), even if such Contributor
+ has been advised of the possibility of such damages.
+
+9. Accepting Warranty or Additional Liability. While redistributing
+ the Work or Derivative Works thereof, You may choose to offer,
+ and charge a fee for, acceptance of support, warranty, indemnity,
+ or other liability obligations and/or rights consistent with this
+ License. However, in accepting such obligations, You may act only
+ on Your own behalf and on Your sole responsibility, not on behalf
+ of any other Contributor, and only if You agree to indemnify,
+ defend, and hold each Contributor harmless for any liability
+ incurred by, or claims asserted against, such Contributor by reason
+ of your accepting any such warranty or additional liability.
+
+END OF TERMS AND CONDITIONS
+
+APPENDIX: How to apply the Apache License to your work.
+
+ To apply the Apache License to your work, attach the following
+ boilerplate notice, with the fields enclosed by brackets "[]"
+ replaced with your own identifying information. (Don't include
+ the brackets!) The text should be enclosed in the appropriate
+ comment syntax for the file format. We also recommend that a
+ file or class name and description of purpose be included on the
+ same "printed page" as the copyright notice for easier
+ identification within third-party archives.
+
+Copyright [yyyy] [name of copyright owner]
+
+Licensed under the Apache License, Version 2.0 (the "License");
+you may not use this file except in compliance with the License.
+You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+Unless required by applicable law or agreed to in writing, software
+distributed under the License is distributed on an "AS IS" BASIS,
+WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+See the License for the specific language governing permissions and
+limitations under the License.
diff --git a/vendor/block-buffer/LICENSE-MIT b/vendor/block-buffer/LICENSE-MIT
new file mode 100644
index 000000000..502cee6e8
--- /dev/null
+++ b/vendor/block-buffer/LICENSE-MIT
@@ -0,0 +1,25 @@
+Copyright (c) 2018-2019 The RustCrypto Project Developers
+
+Permission is hereby granted, free of charge, to any
+person obtaining a copy of this software and associated
+documentation files (the "Software"), to deal in the
+Software without restriction, including without
+limitation the rights to use, copy, modify, merge,
+publish, distribute, sublicense, and/or sell copies of
+the Software, and to permit persons to whom the Software
+is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice
+shall be included in all copies or substantial portions
+of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
+ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
+TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
+PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
+SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
+CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
+IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
diff --git a/vendor/block-buffer/README.md b/vendor/block-buffer/README.md
new file mode 100644
index 000000000..cb134cc91
--- /dev/null
+++ b/vendor/block-buffer/README.md
@@ -0,0 +1,40 @@
+# [RustCrypto]: Block Buffer
+
+[![crate][crate-image]][crate-link]
+[![Docs][docs-image]][docs-link]
+![Apache2/MIT licensed][license-image]
+![Rust Version][rustc-image]
+[![Project Chat][chat-image]][chat-link]
+[![Build Status][build-image]][build-link]
+
+Buffer type for block processing of data with minimized amount of unreachable panics.
+
+## License
+
+Licensed under either of:
+
+ * [Apache License, Version 2.0](http://www.apache.org/licenses/LICENSE-2.0)
+ * [MIT license](http://opensource.org/licenses/MIT)
+
+at your option.
+
+### Contribution
+
+Unless you explicitly state otherwise, any contribution intentionally submitted for inclusion in the work by you, as defined in the Apache-2.0 license, shall be dual licensed as above, without any additional terms or conditions.
+
+[//]: # (badges)
+
+[crate-image]: https://img.shields.io/crates/v/block-buffer.svg
+[crate-link]: https://crates.io/crates/block-buffer
+[docs-image]: https://docs.rs/block-buffer/badge.svg
+[docs-link]: https://docs.rs/block-buffer/
+[license-image]: https://img.shields.io/badge/license-Apache2.0/MIT-blue.svg
+[rustc-image]: https://img.shields.io/badge/rustc-1.41+-blue.svg
+[chat-image]: https://img.shields.io/badge/zulip-join_chat-blue.svg
+[chat-link]: https://rustcrypto.zulipchat.com/#narrow/stream/260052-utils
+[build-image]: https://github.com/RustCrypto/utils/workflows/block-buffer/badge.svg?branch=master&event=push
+[build-link]: https://github.com/RustCrypto/utils/actions/workflows/block-buffer.yml
+
+[//]: # (general links)
+
+[RustCrypto]: https://github.com/rustcrypto
diff --git a/vendor/block-buffer/src/lib.rs b/vendor/block-buffer/src/lib.rs
new file mode 100644
index 000000000..ebe736959
--- /dev/null
+++ b/vendor/block-buffer/src/lib.rs
@@ -0,0 +1,325 @@
+//! Fixed size buffer for block processing of data.
+#![no_std]
+#![doc(
+ html_logo_url = "https://raw.githubusercontent.com/RustCrypto/media/6ee8e381/logo.svg",
+ html_favicon_url = "https://raw.githubusercontent.com/RustCrypto/media/6ee8e381/logo.svg",
+ html_root_url = "https://docs.rs/block-buffer/0.10.2"
+)]
+#![warn(missing_docs, rust_2018_idioms)]
+
+pub use generic_array;
+
+use core::{marker::PhantomData, slice};
+use generic_array::{
+ typenum::{IsLess, Le, NonZero, U256},
+ ArrayLength, GenericArray,
+};
+
+mod sealed;
+
+/// Block on which `BlockBuffer` operates.
+pub type Block<BlockSize> = GenericArray<u8, BlockSize>;
+
+/// Trait for buffer kinds.
+pub trait BufferKind: sealed::Sealed {}
+
+/// Eager block buffer kind, which guarantees that buffer position
+/// always lies in the range of `0..BlockSize`.
+#[derive(Copy, Clone, Debug, Default)]
+pub struct Eager {}
+
+/// Lazy block buffer kind, which guarantees that buffer position
+/// always lies in the range of `0..=BlockSize`.
+#[derive(Copy, Clone, Debug, Default)]
+pub struct Lazy {}
+
+impl BufferKind for Eager {}
+impl BufferKind for Lazy {}
+
+/// Eager block buffer.
+pub type EagerBuffer<B> = BlockBuffer<B, Eager>;
+/// Lazy block buffer.
+pub type LazyBuffer<B> = BlockBuffer<B, Lazy>;
+
+/// Buffer for block processing of data.
+#[derive(Debug)]
+pub struct BlockBuffer<BlockSize, Kind>
+where
+ BlockSize: ArrayLength<u8> + IsLess<U256>,
+ Le<BlockSize, U256>: NonZero,
+ Kind: BufferKind,
+{
+ buffer: Block<BlockSize>,
+ pos: u8,
+ _pd: PhantomData<Kind>,
+}
+
+impl<BlockSize, Kind> Default for BlockBuffer<BlockSize, Kind>
+where
+ BlockSize: ArrayLength<u8> + IsLess<U256>,
+ Le<BlockSize, U256>: NonZero,
+ Kind: BufferKind,
+{
+ fn default() -> Self {
+ Self {
+ buffer: Default::default(),
+ pos: 0,
+ _pd: PhantomData,
+ }
+ }
+}
+
+impl<BlockSize, Kind> Clone for BlockBuffer<BlockSize, Kind>
+where
+ BlockSize: ArrayLength<u8> + IsLess<U256>,
+ Le<BlockSize, U256>: NonZero,
+ Kind: BufferKind,
+{
+ fn clone(&self) -> Self {
+ Self {
+ buffer: self.buffer.clone(),
+ pos: self.pos,
+ _pd: PhantomData,
+ }
+ }
+}
+
+impl<BlockSize, Kind> BlockBuffer<BlockSize, Kind>
+where
+ BlockSize: ArrayLength<u8> + IsLess<U256>,
+ Le<BlockSize, U256>: NonZero,
+ Kind: BufferKind,
+{
+ /// Create new buffer from slice.
+ ///
+ /// # Panics
+ /// If slice length is not valid for used buffer kind.
+ #[inline(always)]
+ pub fn new(buf: &[u8]) -> Self {
+ let pos = buf.len();
+ assert!(Kind::invariant(pos, BlockSize::USIZE));
+ let mut buffer = Block::<BlockSize>::default();
+ buffer[..pos].copy_from_slice(buf);
+ Self {
+ buffer,
+ pos: pos as u8,
+ _pd: PhantomData,
+ }
+ }
+
+ /// Digest data in `input` in blocks of size `BlockSize` using
+ /// the `compress` function, which accepts slice of blocks.
+ #[inline]
+ pub fn digest_blocks(
+ &mut self,
+ mut input: &[u8],
+ mut compress: impl FnMut(&[Block<BlockSize>]),
+ ) {
+ let pos = self.get_pos();
+ // using `self.remaining()` for some reason
+ // prevents panic elimination
+ let rem = self.size() - pos;
+ let n = input.len();
+ // Note that checking condition `pos + n < BlockSize` is
+ // equivalent to checking `n < rem`, where `rem` is equal
+ // to `BlockSize - pos`. Using the latter allows us to work
+ // around compiler accounting for possible overflow of
+ // `pos + n` which results in it inserting unreachable
+ // panic branches. Using `unreachable_unchecked` in `get_pos`
+ // we convince compiler that `BlockSize - pos` never underflows.
+ if Kind::invariant(n, rem) {
+ // double slicing allows to remove panic branches
+ self.buffer[pos..][..n].copy_from_slice(input);
+ self.set_pos_unchecked(pos + n);
+ return;
+ }
+ if pos != 0 {
+ let (left, right) = input.split_at(rem);
+ input = right;
+ self.buffer[pos..].copy_from_slice(left);
+ compress(slice::from_ref(&self.buffer));
+ }
+
+ let (blocks, leftover) = Kind::split_blocks(input);
+ if !blocks.is_empty() {
+ compress(blocks);
+ }
+
+ let n = leftover.len();
+ self.buffer[..n].copy_from_slice(leftover);
+ self.set_pos_unchecked(n);
+ }
+
+ /// Reset buffer by setting cursor position to zero.
+ #[inline(always)]
+ pub fn reset(&mut self) {
+ self.set_pos_unchecked(0);
+ }
+
+ /// Pad remaining data with zeros and return resulting block.
+ #[inline(always)]
+ pub fn pad_with_zeros(&mut self) -> &mut Block<BlockSize> {
+ let pos = self.get_pos();
+ self.buffer[pos..].iter_mut().for_each(|b| *b = 0);
+ self.set_pos_unchecked(0);
+ &mut self.buffer
+ }
+
+ /// Return current cursor position.
+ #[inline(always)]
+ pub fn get_pos(&self) -> usize {
+ let pos = self.pos as usize;
+ if !Kind::invariant(pos, BlockSize::USIZE) {
+ debug_assert!(false);
+ // SAFETY: `pos` never breaks the invariant
+ unsafe {
+ core::hint::unreachable_unchecked();
+ }
+ }
+ pos
+ }
+
+ /// Return slice of data stored inside the buffer.
+ #[inline(always)]
+ pub fn get_data(&self) -> &[u8] {
+ &self.buffer[..self.get_pos()]
+ }
+
+ /// Set buffer content and cursor position.
+ ///
+ /// # Panics
+ /// If `pos` is bigger or equal to block size.
+ #[inline]
+ pub fn set(&mut self, buf: Block<BlockSize>, pos: usize) {
+ assert!(Kind::invariant(pos, BlockSize::USIZE));
+ self.buffer = buf;
+ self.set_pos_unchecked(pos);
+ }
+
+ /// Return size of the internall buffer in bytes.
+ #[inline(always)]
+ pub fn size(&self) -> usize {
+ BlockSize::USIZE
+ }
+
+ /// Return number of remaining bytes in the internall buffer.
+ #[inline(always)]
+ pub fn remaining(&self) -> usize {
+ self.size() - self.get_pos()
+ }
+
+ #[inline(always)]
+ fn set_pos_unchecked(&mut self, pos: usize) {
+ debug_assert!(Kind::invariant(pos, BlockSize::USIZE));
+ self.pos = pos as u8;
+ }
+}
+
+impl<BlockSize> BlockBuffer<BlockSize, Eager>
+where
+ BlockSize: ArrayLength<u8> + IsLess<U256>,
+ Le<BlockSize, U256>: NonZero,
+{
+ /// Set `data` to generated blocks.
+ #[inline]
+ pub fn set_data(
+ &mut self,
+ mut data: &mut [u8],
+ mut process_blocks: impl FnMut(&mut [Block<BlockSize>]),
+ ) {
+ let pos = self.get_pos();
+ let r = self.remaining();
+ let n = data.len();
+ if pos != 0 {
+ if n < r {
+ // double slicing allows to remove panic branches
+ data.copy_from_slice(&self.buffer[pos..][..n]);
+ self.set_pos_unchecked(pos + n);
+ return;
+ }
+ let (left, right) = data.split_at_mut(r);
+ data = right;
+ left.copy_from_slice(&self.buffer[pos..]);
+ }
+
+ let (blocks, leftover) = to_blocks_mut(data);
+ process_blocks(blocks);
+
+ let n = leftover.len();
+ if n != 0 {
+ let mut block = Default::default();
+ process_blocks(slice::from_mut(&mut block));
+ leftover.copy_from_slice(&block[..n]);
+ self.buffer = block;
+ }
+ self.set_pos_unchecked(n);
+ }
+
+ /// Compress remaining data after padding it with `delim`, zeros and
+ /// the `suffix` bytes. If there is not enough unused space, `compress`
+ /// will be called twice.
+ ///
+ /// # Panics
+ /// If suffix length is bigger than block size.
+ #[inline(always)]
+ pub fn digest_pad(
+ &mut self,
+ delim: u8,
+ suffix: &[u8],
+ mut compress: impl FnMut(&Block<BlockSize>),
+ ) {
+ if suffix.len() > BlockSize::USIZE {
+ panic!("suffix is too long");
+ }
+ let pos = self.get_pos();
+ self.buffer[pos] = delim;
+ for b in &mut self.buffer[pos + 1..] {
+ *b = 0;
+ }
+
+ let n = self.size() - suffix.len();
+ if self.size() - pos - 1 < suffix.len() {
+ compress(&self.buffer);
+ let mut block = Block::<BlockSize>::default();
+ block[n..].copy_from_slice(suffix);
+ compress(&block);
+ } else {
+ self.buffer[n..].copy_from_slice(suffix);
+ compress(&self.buffer);
+ }
+ self.set_pos_unchecked(0)
+ }
+
+ /// Pad message with 0x80, zeros and 64-bit message length using
+ /// big-endian byte order.
+ #[inline]
+ pub fn len64_padding_be(&mut self, data_len: u64, compress: impl FnMut(&Block<BlockSize>)) {
+ self.digest_pad(0x80, &data_len.to_be_bytes(), compress);
+ }
+
+ /// Pad message with 0x80, zeros and 64-bit message length using
+ /// little-endian byte order.
+ #[inline]
+ pub fn len64_padding_le(&mut self, data_len: u64, compress: impl FnMut(&Block<BlockSize>)) {
+ self.digest_pad(0x80, &data_len.to_le_bytes(), compress);
+ }
+
+ /// Pad message with 0x80, zeros and 128-bit message length using
+ /// big-endian byte order.
+ #[inline]
+ pub fn len128_padding_be(&mut self, data_len: u128, compress: impl FnMut(&Block<BlockSize>)) {
+ self.digest_pad(0x80, &data_len.to_be_bytes(), compress);
+ }
+}
+
+/// Split message into mutable slice of parallel blocks, blocks, and leftover bytes.
+#[inline(always)]
+fn to_blocks_mut<N: ArrayLength<u8>>(data: &mut [u8]) -> (&mut [Block<N>], &mut [u8]) {
+ let nb = data.len() / N::USIZE;
+ let (left, right) = data.split_at_mut(nb * N::USIZE);
+ let p = left.as_mut_ptr() as *mut Block<N>;
+ // SAFETY: we guarantee that `blocks` does not point outside of `data`, and `p` is valid for
+ // mutation
+ let blocks = unsafe { slice::from_raw_parts_mut(p, nb) };
+ (blocks, right)
+}
diff --git a/vendor/block-buffer/src/sealed.rs b/vendor/block-buffer/src/sealed.rs
new file mode 100644
index 000000000..371a8b703
--- /dev/null
+++ b/vendor/block-buffer/src/sealed.rs
@@ -0,0 +1,67 @@
+use super::{ArrayLength, Block};
+use core::slice;
+
+/// Sealed trait for buffer kinds.
+pub trait Sealed {
+ /// Invariant guaranteed by a buffer kind, i.e. with correct
+ /// buffer code this function always returns true.
+ fn invariant(pos: usize, block_size: usize) -> bool;
+
+ /// Split input data into slice fo blocks and tail.
+ fn split_blocks<N: ArrayLength<u8>>(data: &[u8]) -> (&[Block<N>], &[u8]);
+}
+
+impl Sealed for super::Eager {
+ #[inline(always)]
+ fn invariant(pos: usize, block_size: usize) -> bool {
+ pos < block_size
+ }
+
+ #[inline(always)]
+ fn split_blocks<N: ArrayLength<u8>>(data: &[u8]) -> (&[Block<N>], &[u8]) {
+ let nb = data.len() / N::USIZE;
+ let blocks_len = nb * N::USIZE;
+ let tail_len = data.len() - blocks_len;
+ // SAFETY: we guarantee that created slices do not point
+ // outside of `data`
+ unsafe {
+ let blocks_ptr = data.as_ptr() as *const Block<N>;
+ let tail_ptr = data.as_ptr().add(blocks_len);
+ (
+ slice::from_raw_parts(blocks_ptr, nb),
+ slice::from_raw_parts(tail_ptr, tail_len),
+ )
+ }
+ }
+}
+
+impl Sealed for super::Lazy {
+ #[inline(always)]
+ fn invariant(pos: usize, block_size: usize) -> bool {
+ pos <= block_size
+ }
+
+ #[inline(always)]
+ fn split_blocks<N: ArrayLength<u8>>(data: &[u8]) -> (&[Block<N>], &[u8]) {
+ if data.is_empty() {
+ return (&[], &[]);
+ }
+ let (nb, tail_len) = if data.len() % N::USIZE == 0 {
+ (data.len() / N::USIZE - 1, N::USIZE)
+ } else {
+ let nb = data.len() / N::USIZE;
+ (nb, data.len() - nb * N::USIZE)
+ };
+ let blocks_len = nb * N::USIZE;
+ // SAFETY: we guarantee that created slices do not point
+ // outside of `data`
+ unsafe {
+ let blocks_ptr = data.as_ptr() as *const Block<N>;
+ let tail_ptr = data.as_ptr().add(blocks_len);
+ (
+ slice::from_raw_parts(blocks_ptr, nb),
+ slice::from_raw_parts(tail_ptr, tail_len),
+ )
+ }
+ }
+}
diff --git a/vendor/block-buffer/tests/mod.rs b/vendor/block-buffer/tests/mod.rs
new file mode 100644
index 000000000..6dfa1ae14
--- /dev/null
+++ b/vendor/block-buffer/tests/mod.rs
@@ -0,0 +1,188 @@
+use block_buffer::{
+ generic_array::typenum::{U10, U16, U24, U4, U8},
+ Block, EagerBuffer, LazyBuffer,
+};
+
+#[test]
+fn test_eager_digest_pad() {
+ let mut buf = EagerBuffer::<U4>::default();
+ let inputs = [
+ &b"01234567"[..],
+ &b"89"[..],
+ &b"abcdefghij"[..],
+ &b"klmnopqrs"[..],
+ &b"tuv"[..],
+ &b"wx"[..],
+ ];
+ let exp_blocks = [
+ (0, &[b"0123", b"4567"][..]),
+ (2, &[b"89ab"][..]),
+ (2, &[b"cdef", b"ghij"][..]),
+ (3, &[b"klmn", b"opqr"][..]),
+ (4, &[b"stuv"][..]),
+ ];
+ let exp_poses = [0, 2, 0, 1, 0, 2];
+
+ let mut n = 0;
+ for (i, input) in inputs.iter().enumerate() {
+ buf.digest_blocks(input, |b| {
+ let (j, exp) = exp_blocks[n];
+ n += 1;
+ assert_eq!(i, j);
+ assert_eq!(b.len(), exp.len());
+ assert!(b.iter().zip(exp.iter()).all(|v| v.0[..] == v.1[..]));
+ });
+ assert_eq!(exp_poses[i], buf.get_pos());
+ }
+ assert_eq!(buf.pad_with_zeros()[..], b"wx\0\0"[..]);
+ assert_eq!(buf.get_pos(), 0);
+}
+
+#[test]
+fn test_lazy_digest_pad() {
+ let mut buf = LazyBuffer::<U4>::default();
+ let inputs = [
+ &b"01234567"[..],
+ &b"89"[..],
+ &b"abcdefghij"[..],
+ &b"klmnopqrs"[..],
+ ];
+ let expected = [
+ (0, &[b"0123"][..]),
+ (1, &[b"4567"][..]),
+ (2, &[b"89ab"][..]),
+ (2, &[b"cdef"][..]),
+ (3, &[b"ghij"][..]),
+ (3, &[b"klmn", b"opqr"][..]),
+ ];
+ let exp_poses = [4, 2, 4, 1];
+
+ let mut n = 0;
+ for (i, input) in inputs.iter().enumerate() {
+ buf.digest_blocks(input, |b| {
+ let (j, exp) = expected[n];
+ n += 1;
+ assert_eq!(i, j);
+ assert_eq!(b.len(), exp.len());
+ assert!(b.iter().zip(exp.iter()).all(|v| v.0[..] == v.1[..]));
+ });
+ assert_eq!(exp_poses[i], buf.get_pos());
+ }
+ assert_eq!(buf.pad_with_zeros()[..], b"s\0\0\0"[..]);
+ assert_eq!(buf.get_pos(), 0);
+}
+
+#[test]
+fn test_eager_set_data() {
+ let mut buf = EagerBuffer::<U4>::default();
+
+ let mut n = 0u8;
+ let mut gen = |blocks: &mut [Block<U4>]| {
+ for block in blocks {
+ block.iter_mut().for_each(|b| *b = n);
+ n += 1;
+ }
+ };
+
+ let mut out = [0u8; 6];
+ buf.set_data(&mut out, &mut gen);
+ assert_eq!(out, [0, 0, 0, 0, 1, 1]);
+ assert_eq!(buf.get_pos(), 2);
+
+ let mut out = [0u8; 3];
+ buf.set_data(&mut out, &mut gen);
+ assert_eq!(out, [1, 1, 2]);
+ assert_eq!(buf.get_pos(), 1);
+
+ let mut out = [0u8; 3];
+ buf.set_data(&mut out, &mut gen);
+ assert_eq!(out, [2, 2, 2]);
+ assert_eq!(n, 3);
+ assert_eq!(buf.get_pos(), 0);
+}
+
+#[test]
+#[rustfmt::skip]
+fn test_eager_paddings() {
+ let mut buf_be = EagerBuffer::<U8>::new(&[0x42]);
+ let mut buf_le = buf_be.clone();
+ let mut out_be = Vec::<u8>::new();
+ let mut out_le = Vec::<u8>::new();
+ let len = 0x0001_0203_0405_0607;
+ buf_be.len64_padding_be(len, |block| out_be.extend(block));
+ buf_le.len64_padding_le(len, |block| out_le.extend(block));
+
+ assert_eq!(
+ out_be,
+ [
+ 0x42, 0x80, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
+ 0x00, 0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07,
+ ],
+ );
+ assert_eq!(
+ out_le,
+ [
+ 0x42, 0x80, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
+ 0x07, 0x06, 0x05, 0x04, 0x03, 0x02, 0x01, 0x00,
+ ],
+ );
+
+ let mut buf_be = EagerBuffer::<U10>::new(&[0x42]);
+ let mut buf_le = buf_be.clone();
+ let mut out_be = Vec::<u8>::new();
+ let mut out_le = Vec::<u8>::new();
+ buf_be.len64_padding_be(len, |block| out_be.extend(block));
+ buf_le.len64_padding_le(len, |block| out_le.extend(block));
+
+ assert_eq!(
+ out_be,
+ [0x42, 0x80, 0x00, 0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07],
+ );
+ assert_eq!(
+ out_le,
+ [0x42, 0x80, 0x07, 0x06, 0x05, 0x04, 0x03, 0x02, 0x01, 0x00],
+ );
+
+ let mut buf = EagerBuffer::<U16>::new(&[0x42]);
+ let mut out = Vec::<u8>::new();
+ let len = 0x0001_0203_0405_0607_0809_0a0b_0c0d_0e0f;
+ buf.len128_padding_be(len, |block| out.extend(block));
+ assert_eq!(
+ out,
+ [
+ 0x42, 0x80, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
+ 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
+ 0x00, 0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07,
+ 0x08, 0x09, 0x0a, 0x0b, 0x0c, 0x0d, 0x0e, 0x0f,
+ ],
+ );
+
+ let mut buf = EagerBuffer::<U24>::new(&[0x42]);
+ let mut out = Vec::<u8>::new();
+ let len = 0x0001_0203_0405_0607_0809_0a0b_0c0d_0e0f;
+ buf.len128_padding_be(len, |block| out.extend(block));
+ assert_eq!(
+ out,
+ [
+ 0x42, 0x80, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00,
+ 0x00, 0x01, 0x02, 0x03, 0x04, 0x05, 0x06, 0x07,
+ 0x08, 0x09, 0x0a, 0x0b, 0x0c, 0x0d, 0x0e, 0x0f,
+ ],
+ );
+
+ let mut buf = EagerBuffer::<U4>::new(&[0x42]);
+ let mut out = Vec::<u8>::new();
+ buf.digest_pad(0xff, &[0x10, 0x11, 0x12], |block| out.extend(block));
+ assert_eq!(
+ out,
+ [0x42, 0xff, 0x00, 0x00, 0x00, 0x10, 0x11, 0x12],
+ );
+
+ let mut buf = EagerBuffer::<U4>::new(&[0x42]);
+ let mut out = Vec::<u8>::new();
+ buf.digest_pad(0xff, &[0x10, 0x11], |block| out.extend(block));
+ assert_eq!(
+ out,
+ [0x42, 0xff, 0x10, 0x11],
+ );
+}