summaryrefslogtreecommitdiffstats
path: root/vendor/btoi/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:41:41 +0000
commit10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87 (patch)
treebdffd5d80c26cf4a7a518281a204be1ace85b4c1 /vendor/btoi/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg1-9~progress7.99u1. (diff)
downloadrustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.tar.xz
rustc-10ee2acdd26a7f1298c6f6d6b7af9b469fe29b87.zip
Merging upstream version 1.70.0+dfsg2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/btoi/Cargo.toml')
-rw-r--r--vendor/btoi/Cargo.toml44
1 files changed, 44 insertions, 0 deletions
diff --git a/vendor/btoi/Cargo.toml b/vendor/btoi/Cargo.toml
new file mode 100644
index 000000000..b461b83ef
--- /dev/null
+++ b/vendor/btoi/Cargo.toml
@@ -0,0 +1,44 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "btoi"
+version = "0.4.3"
+authors = ["Niklas Fiekas <niklas.fiekas@backscattering.de>"]
+description = "Parse integers directly from ASCII byte slices"
+readme = "README.md"
+keywords = [
+ "conversion",
+ "integer",
+ "atoi",
+ "no_std",
+]
+categories = ["parsing"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/niklasf/rust-btoi"
+
+[[bench]]
+name = "benches"
+harness = false
+
+[dependencies.num-traits]
+version = "0.2"
+default-features = false
+
+[dev-dependencies.bencher]
+version = "0.1"
+
+[dev-dependencies.quickcheck]
+version = "1"
+
+[features]
+default = ["std"]
+std = ["num-traits/std"]