summaryrefslogtreecommitdiffstats
path: root/vendor/bytes/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/bytes/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/bytes/Cargo.toml')
-rw-r--r--vendor/bytes/Cargo.toml39
1 files changed, 28 insertions, 11 deletions
diff --git a/vendor/bytes/Cargo.toml b/vendor/bytes/Cargo.toml
index d102cf061..d0acb3421 100644
--- a/vendor/bytes/Cargo.toml
+++ b/vendor/bytes/Cargo.toml
@@ -3,35 +3,52 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
name = "bytes"
-version = "1.0.1"
-authors = ["Carl Lerche <me@carllerche.com>", "Sean McArthur <sean@seanmonstar.com>"]
+version = "1.4.0"
+authors = [
+ "Carl Lerche <me@carllerche.com>",
+ "Sean McArthur <sean@seanmonstar.com>",
+]
description = "Types and traits for working with bytes"
-documentation = "https://docs.rs/bytes/1.0.1/bytes/"
readme = "README.md"
-keywords = ["buffers", "zero-copy", "io"]
-categories = ["network-programming", "data-structures"]
+keywords = [
+ "buffers",
+ "zero-copy",
+ "io",
+]
+categories = [
+ "network-programming",
+ "data-structures",
+]
license = "MIT"
repository = "https://github.com/tokio-rs/bytes"
+
+[package.metadata.docs.rs]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
[dependencies.serde]
version = "1.0.60"
features = ["alloc"]
optional = true
default-features = false
+
[dev-dependencies.serde_test]
version = "1.0"
[features]
default = ["std"]
std = []
+
[target."cfg(loom)".dev-dependencies.loom]
-version = "0.4"
+version = "0.5"