summaryrefslogtreecommitdiffstats
path: root/vendor/chalk-solve-0.87.0/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-30 03:57:31 +0000
commitdc0db358abe19481e475e10c32149b53370f1a1c (patch)
treeab8ce99c4b255ce46f99ef402c27916055b899ee /vendor/chalk-solve-0.87.0/Cargo.toml
parentReleasing progress-linux version 1.71.1+dfsg1-2~progress7.99u1. (diff)
downloadrustc-dc0db358abe19481e475e10c32149b53370f1a1c.tar.xz
rustc-dc0db358abe19481e475e10c32149b53370f1a1c.zip
Merging upstream version 1.72.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/chalk-solve-0.87.0/Cargo.toml')
-rw-r--r--vendor/chalk-solve-0.87.0/Cargo.toml70
1 files changed, 0 insertions, 70 deletions
diff --git a/vendor/chalk-solve-0.87.0/Cargo.toml b/vendor/chalk-solve-0.87.0/Cargo.toml
deleted file mode 100644
index b57214aa8..000000000
--- a/vendor/chalk-solve-0.87.0/Cargo.toml
+++ /dev/null
@@ -1,70 +0,0 @@
-# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
-#
-# When uploading crates to the registry Cargo will automatically
-# "normalize" Cargo.toml files for maximal compatibility
-# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies.
-#
-# If you are reading this file be aware that the original Cargo.toml
-# will likely look very different (and much more reasonable).
-# See Cargo.toml.orig for the original contents.
-
-[package]
-edition = "2018"
-name = "chalk-solve"
-version = "0.87.0"
-authors = [
- "Rust Compiler Team",
- "Chalk developers",
-]
-description = "Combines the chalk-engine with chalk-ir"
-readme = "README.md"
-keywords = [
- "compiler",
- "traits",
- "prolog",
-]
-license = "MIT OR Apache-2.0"
-repository = "https://github.com/rust-lang/chalk"
-
-[dependencies.chalk-derive]
-version = "=0.87.0"
-
-[dependencies.chalk-ir]
-version = "=0.87.0"
-
-[dependencies.ena]
-version = "0.14.0"
-
-[dependencies.indexmap]
-version = "1.8.0"
-
-[dependencies.itertools]
-version = "0.10.0"
-
-[dependencies.petgraph]
-version = "0.5.1"
-
-[dependencies.rustc-hash]
-version = "1.1.0"
-
-[dependencies.tracing]
-version = "0.1"
-
-[dependencies.tracing-subscriber]
-version = "0.3"
-features = ["env-filter"]
-optional = true
-
-[dependencies.tracing-tree]
-version = "0.2"
-optional = true
-
-[dev-dependencies]
-
-[features]
-default = ["tracing-full"]
-tracing-full = [
- "tracing-subscriber",
- "tracing-tree",
-]