summaryrefslogtreecommitdiffstats
path: root/vendor/chrono/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-18 02:49:50 +0000
commit9835e2ae736235810b4ea1c162ca5e65c547e770 (patch)
tree3fcebf40ed70e581d776a8a4c65923e8ec20e026 /vendor/chrono/Cargo.toml
parentReleasing progress-linux version 1.70.0+dfsg2-1~progress7.99u1. (diff)
downloadrustc-9835e2ae736235810b4ea1c162ca5e65c547e770.tar.xz
rustc-9835e2ae736235810b4ea1c162ca5e65c547e770.zip
Merging upstream version 1.71.1+dfsg1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/chrono/Cargo.toml')
-rw-r--r--vendor/chrono/Cargo.toml97
1 files changed, 70 insertions, 27 deletions
diff --git a/vendor/chrono/Cargo.toml b/vendor/chrono/Cargo.toml
index 2d3e76433..eaf0e6945 100644
--- a/vendor/chrono/Cargo.toml
+++ b/vendor/chrono/Cargo.toml
@@ -3,28 +3,36 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
+edition = "2018"
name = "chrono"
-version = "0.4.19"
-authors = ["Kang Seonghoon <public+rust@mearie.org>", "Brandon W Maister <quodlibetor@gmail.com>"]
-exclude = ["/ci/*", "/.travis.yml", "/appveyor.yml", "/Makefile"]
+version = "0.4.24"
+exclude = ["/ci/*"]
description = "Date and time library for Rust"
homepage = "https://github.com/chronotope/chrono"
documentation = "https://docs.rs/chrono/"
readme = "README.md"
-keywords = ["date", "time", "calendar"]
+keywords = [
+ "date",
+ "time",
+ "calendar",
+]
categories = ["date-and-time"]
license = "MIT/Apache-2.0"
repository = "https://github.com/chronotope/chrono"
+
[package.metadata.docs.rs]
features = ["serde"]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
[package.metadata.playground]
features = ["serde"]
@@ -40,9 +48,18 @@ required-features = ["__internal_bench"]
[[bench]]
name = "serde"
harness = false
-required-features = ["serde"]
-[dependencies.libc]
-version = "0.2.69"
+required-features = [
+ "__internal_bench",
+ "serde",
+]
+
+[dependencies.arbitrary]
+version = "1.0.0"
+features = ["derive"]
+optional = true
+
+[dependencies.criterion]
+version = "0.4.0"
optional = true
[dependencies.num-integer]
@@ -57,6 +74,10 @@ default-features = false
version = "0.5.2"
optional = true
+[dependencies.rkyv]
+version = "0.7"
+optional = true
+
[dependencies.rustc-serialize]
version = "0.3.20"
optional = true
@@ -69,11 +90,9 @@ default-features = false
[dependencies.time]
version = "0.1.43"
optional = true
-[dev-dependencies.bincode]
-version = "0.8.0"
-[dev-dependencies.criterion]
-version = "0.3"
+[dev-dependencies.bincode]
+version = "1.3.0"
[dev-dependencies.doc-comment]
version = "0.3"
@@ -91,14 +110,31 @@ version = "1"
[features]
__doctest = []
-__internal_bench = []
+__internal_bench = ["criterion"]
alloc = []
-clock = ["libc", "std", "winapi"]
-default = ["clock", "std", "oldtime"]
+clock = [
+ "std",
+ "winapi",
+ "iana-time-zone",
+]
+default = [
+ "clock",
+ "std",
+ "oldtime",
+ "wasmbind",
+]
+libc = []
oldtime = ["time"]
std = []
-unstable-locales = ["pure-rust-locales", "alloc"]
-wasmbind = ["wasm-bindgen", "js-sys"]
+unstable-locales = [
+ "pure-rust-locales",
+ "alloc",
+]
+wasmbind = [
+ "wasm-bindgen",
+ "js-sys",
+]
+
[target."cfg(all(target_arch = \"wasm32\", not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dependencies.js-sys]
version = "0.3"
optional = true
@@ -106,14 +142,21 @@ optional = true
[target."cfg(all(target_arch = \"wasm32\", not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dependencies.wasm-bindgen]
version = "0.2"
optional = true
+
[target."cfg(all(target_arch = \"wasm32\", not(any(target_os = \"emscripten\", target_os = \"wasi\"))))".dev-dependencies.wasm-bindgen-test]
version = "0.3"
+
+[target."cfg(unix)".dependencies.iana-time-zone]
+version = "0.1.45"
+features = ["fallback"]
+optional = true
+
[target."cfg(windows)".dependencies.winapi]
version = "0.3.0"
-features = ["std", "minwinbase", "minwindef", "timezoneapi"]
+features = [
+ "std",
+ "minwinbase",
+ "minwindef",
+ "timezoneapi",
+]
optional = true
-[badges.appveyor]
-repository = "chronotope/chrono"
-
-[badges.travis-ci]
-repository = "chronotope/chrono"